Last Comment Bug 771825 - options.loadReason is undefined on 1.8
: options.loadReason is undefined on 1.8
Status: RESOLVED FIXED
:
Product: Add-on SDK
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Irakli Gozalishvili [:irakli] [:gozala] [@gozala]
:
Mentors:
: 778604 (view as bug list)
Depends on:
Blocks: 772294
  Show dependency treegraph
 
Reported: 2012-07-07 12:04 PDT by Jeff Griffiths (:canuckistani) (:⚡︎)
Modified: 2012-07-29 18:38 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Pointer to Github pull request: https://github.com/mozilla/addon-sdk/pull/483 (355 bytes, text/html)
2012-07-09 14:35 PDT, Irakli Gozalishvili [:irakli] [:gozala] [@gozala]
dtownsend: review+
wkocher: feedback+
Details

Description Jeff Griffiths (:canuckistani) (:⚡︎) 2012-07-07 12:04:37 PDT
Reported here: http://is.gd/EbT0p1

Repro:

https://builder.addons.mozilla.org/addon/1064871/latest/

By design?
Comment 1 Jeff Griffiths (:canuckistani) (:⚡︎) 2012-07-07 13:06:33 PDT
I think we need to roll a 1.8.1 to fix this, ASAP.
Comment 2 Jeff Griffiths (:canuckistani) (:⚡︎) 2012-07-07 13:42:34 PDT
We probably need to cherry-pick this change into release:

https://github.com/mozilla/addon-sdk/commit/cda1c015ce31cf890f93d32cd0b15b741793cf47
Comment 3 Wes Kocher (:KWierso) 2012-07-07 14:26:53 PDT
(In reply to Jeff Griffiths from comment #0)
> Repro:
> 
> https://builder.addons.mozilla.org/addon/1064871/latest/
This still fails for me with cda1c015 cherry picked (after cleaning up the merge conflicts.
Irakli, is there anything else before that commit that needed to be included as well for this to work?
Comment 4 Irakli Gozalishvili [:irakli] [:gozala] [@gozala] 2012-07-09 14:35:34 PDT
Created attachment 640362 [details]
Pointer to Github pull request: https://github.com/mozilla/addon-sdk/pull/483

Pointer to Github pull-request
Comment 5 [github robot] 2012-07-09 14:45:38 PDT
Commit pushed to release at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/1992402871cbe3c619a4c18070dda312269ad2ec
Merge pull request #483 from Gozala/hotfix/load-reason@771825

Bug 771825 - options.loadReason is undefined on 1.8 r=mossop
Comment 6 [github robot] 2012-07-10 11:14:55 PDT
Commit pushed to stabilization at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/1992402871cbe3c619a4c18070dda312269ad2ec
Merge pull request #483 from Gozala/hotfix/load-reason@771825
Comment 7 Dave Townsend [:mossop] 2012-07-29 18:38:38 PDT
*** Bug 778604 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.