Last Comment Bug 771870 - adding files to js/src seems to require a clobber on tinderbox, sometimes
: adding files to js/src seems to require a clobber on tinderbox, sometimes
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: Mike Hommey [:glandium]
:
: Gregory Szorc [:gps]
Mentors:
Depends on: 775627
Blocks: clobber 763987
  Show dependency treegraph
 
Reported: 2012-07-07 22:12 PDT by Luke Wagner [:luke]
Modified: 2013-11-21 14:33 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Avoid js/src/Makefile being created with wrong topsrcdir (2.52 KB, patch)
2012-07-08 02:12 PDT, Mike Hommey [:glandium]
khuey: review+
Details | Diff | Splinter Review

Description Luke Wagner [:luke] 2012-07-07 22:12:30 PDT
Here is one example:
  https://hg.mozilla.org/integration/mozilla-inbound/rev/c9b0e6294a7c
with log:
  https://tbpl.mozilla.org/php/getParsedLog.php?id=13324602&tree=Mozilla-Inbound&full=1

Here is another:
  https://hg.mozilla.org/integration/mozilla-inbound/rev/8417741974ba

Both involve adding files to js/src/Makefile.in that are not INSTALLED_HEADERS.

Another clue is that philor pointed out that these are the only csets to add files after bug 748001.
Comment 1 David Baron :dbaron: ⌚️UTC-8 2012-07-07 22:21:46 PDT
Comparing a good log to a failed log, one thing that seems to have gone wrong is that a good log:

https://tbpl.mozilla.org/php/getParsedLog.php?id=13317288&tree=Mozilla-Inbound

contains the export line:
/builds/slave/m-in-lnx/build/obj-firefox/js/src/config/nsinstall -R -m 644 /builds/slave/m-in-lnx/build/js/src/../public/HashTable.h /builds/slave/m-in-lnx/build/js/src/../public/LegacyIntTypes.h /builds/slave/m-in-lnx/build/js/src/../public/MemoryMetrics.h /builds/slave/m-in-lnx/build/js/src/../public/TemplateLib.h /builds/slave/m-in-lnx/build/js/src/../public/Utility.h /builds/slave/m-in-lnx/build/js/src/../public/Vector.h ./../../dist/include/js

while a bad log:

https://tbpl.mozilla.org/php/getParsedLog.php?id=13324597&tree=Mozilla-Inbound

contains the export line:
/builds/slave/m-in-lnx/build/obj-firefox/js/src/config/nsinstall -R -m 644 /builds/slave/m-in-lnx/build/js/src/../public/HashTable.h /builds/slave/m-in-lnx/build/js/src/../public/LegacyIntTypes.h /builds/slave/m-in-lnx/build/js/src/../public/MemoryMetrics.h /builds/slave/m-in-lnx/build/js/src/../public/TemplateLib.h /builds/slave/m-in-lnx/build/js/src/../public/Utility.h /builds/slave/m-in-lnx/build/js/src/../public/Vector.h ./dist/include/js


Notice that the later export line is installing to "./dist/include/js" instead of "./../../dist/include/js".  That seems broken.
Comment 2 Mike Hommey [:glandium] 2012-07-08 00:25:35 PDT
Likely related to bug 763987
Comment 3 Mike Hommey [:glandium] 2012-07-08 01:17:41 PDT
So, the problem is actually very old, but before bug 763987 it wasn't really important: objdir/js/src/Makefile is created from the top directory with:
/usr/bin/perl $srcdir/build/autoconf/make-makefile -t $topsrcdir -d . js/src/Makefile

topsrcdir is thus wrong in js/src/Makefile.
Comment 4 Mike Hommey [:glandium] 2012-07-08 01:18:55 PDT
(In reply to Mike Hommey [:glandium] from comment #3)
> topsrcdir is thus wrong in js/src/Makefile.

and DEPTH, too.
Comment 5 Mike Hommey [:glandium] 2012-07-08 01:19:41 PDT
(In reply to Mike Hommey [:glandium] from comment #4)
> (In reply to Mike Hommey [:glandium] from comment #3)
> > topsrcdir is thus wrong in js/src/Makefile.
> 
> and DEPTH, too.

huh, no, DEPTH is hardcoded.
Comment 6 Mike Hommey [:glandium] 2012-07-08 02:12:05 PDT
Created attachment 640036 [details] [diff] [review]
Avoid js/src/Makefile being created with wrong topsrcdir
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-07-09 18:04:37 PDT
https://hg.mozilla.org/mozilla-central/rev/138751d54763

Note You need to log in before you can comment on or make changes to this bug.