Last Comment Bug 771892 - [New Tab Page] check for private browsing mode *every* time a user drags a link onto the grid
: [New Tab Page] check for private browsing mode *every* time a user drags a li...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 16
Assigned To: Tim Taubert [:ttaubert]
:
Mentors:
Depends on:
Blocks: 722990 753448
  Show dependency treegraph
 
Reported: 2012-07-08 04:04 PDT by Tim Taubert [:ttaubert]
Modified: 2012-07-10 02:07 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
trivial patch (2.73 KB, patch)
2012-07-08 04:04 PDT, Tim Taubert [:ttaubert]
ehsan: review+
Details | Diff | Review

Description Tim Taubert [:ttaubert] 2012-07-08 04:04:14 PDT
Created attachment 640048 [details] [diff] [review]
trivial patch

Currently, we're only checking once when loading about:newtab if the parent window is in private browsing mode (as implemented in bug 722990). We need to check every time the user attempts a drag because the tab might have been moved to another window or the windows private browsing status might have changed since the page loaded.
Comment 1 Tim Taubert [:ttaubert] 2012-07-09 15:37:34 PDT
https://hg.mozilla.org/integration/fx-team/rev/90c8e72e00b6
Comment 2 Tim Taubert [:ttaubert] 2012-07-10 02:07:05 PDT
https://hg.mozilla.org/mozilla-central/rev/90c8e72e00b6

Note You need to log in before you can comment on or make changes to this bug.