Last Comment Bug 771900 - don't have presentation attributes for properties we don't support
: don't have presentation attributes for properties we don't support
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: Cameron McCormack (:heycam) (away Jun 25 – Jul 10)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-08 05:18 PDT by Cameron McCormack (:heycam) (away Jun 25 – Jul 10)
Modified: 2012-07-09 04:50 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.11 KB, patch)
2012-07-08 05:18 PDT, Cameron McCormack (:heycam) (away Jun 25 – Jul 10)
jwatt: review+
Details | Diff | Review

Description Cameron McCormack (:heycam) (away Jun 25 – Jul 10) 2012-07-08 05:18:18 PDT
Created attachment 640055 [details] [diff] [review]
patch

Trying to use them in a debug build causes a crash due to the NS_ABORT_IF_FALSE in MappedAttrParser::ParseMappedAttrValue.
Comment 1 Jonathan Watt [:jwatt] (Away Jun. 27 - Jul. 13) 2012-07-08 07:56:30 PDT
Comment on attachment 640055 [details] [diff] [review]
patch

r=jwatt, but can you comment them out rather than remove them, and put a comment before each commented out block mentioning that they are not yet supported?
Comment 2 Cameron McCormack (:heycam) (away Jun 25 – Jul 10) 2012-07-08 18:12:48 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/29a65f751021
Comment 3 Ed Morley [:emorley] 2012-07-09 04:50:04 PDT
https://hg.mozilla.org/mozilla-central/rev/29a65f751021

Note You need to log in before you can comment on or make changes to this bug.