Last Comment Bug 771908 - Get rid of Wrapper::leave
: Get rid of Wrapper::leave
Status: RESOLVED FIXED
[js:t]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Eddy Bruel [:ejpbruel]
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: 772138
  Show dependency treegraph
 
Reported: 2012-07-08 07:07 PDT by Eddy Bruel [:ejpbruel]
Modified: 2013-07-10 11:53 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch to be reviewed (9.58 KB, patch)
2012-07-09 08:50 PDT, Eddy Bruel [:ejpbruel]
bobbyholley: review+
mrbkap: superreview+
Details | Diff | Splinter Review

Description Eddy Bruel [:ejpbruel] 2012-07-08 07:07:34 PDT
Our policy enforcement mechanism for wrappers currently consists of a single call to Wrapper::enter, followed by a single call to Wrapper::leave. The latter call, however, is strictly unnecessary, since every implementation of it is currently empty. There is no reason to assume that this will change anytime soon, so we might as well get rid of this superfluous call.
Comment 1 Eddy Bruel [:ejpbruel] 2012-07-09 08:50:00 PDT
Created attachment 640240 [details] [diff] [review]
Patch to be reviewed
Comment 2 Bobby Holley (:bholley) (busy with Stylo) 2012-07-09 09:01:40 PDT
Comment on attachment 640240 [details] [diff] [review]
Patch to be reviewed

r=bholley. But let's just double-check to make sure mrbkap is ok with it.
Comment 4 Ed Morley [:emorley] 2012-07-12 09:40:31 PDT
https://hg.mozilla.org/mozilla-central/rev/ba89d552b9dc

Note You need to log in before you can comment on or make changes to this bug.