Closed Bug 771989 Opened 7 years ago Closed 7 years ago

Virtual keyboard is dismissed when in Find in Page highlights a link

Categories

(Firefox for Android :: Keyboards and IME, defect)

16 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 17
Tracking Status
firefox15 + verified
firefox16 + verified
firefox17 --- verified

People

(Reporter: AdrianT, Assigned: mbrubeck)

References

Details

(Keywords: reproducible)

Attachments

(2 files, 1 obsolete file)

Attached file logs
This is a follow-up bug for bug 760087

Nightly 16.0a1 2012-07-08/ Aurora 15.0a2 2012-07-08
Device: Google Nexus(Android 4.0.2), HTC Desire(Android 2.2.2)

Steps to reproduce:
1. Go to neowin.com.
2. Open the menu and select "find in page".
3. Start typing "windows".

Expected results:
The user can perform a search.

Actual results:
When "w" is typed the vkb is dismissed. Whenever the highlight is moved to another word the virtual keyboard is dismissed again.

Notes:
Please see the videocapture: http://youtu.be/YY2yitQh8nU
Blocks: 760087
We're not using the blocking-flag anymore.
tracking-fennec: --- → ?
blocking-fennec1.0: ? → ---
Blocks: find
Matt, thoughts?
I'll take a look...
Assignee: nobody → mbrubeck
I don't see anything obvious; the focus does not seem to be stolen in the same way it was in bug 760087.  If someone has time to bisect this, it would be useful to know a regression range.
Status: NEW → ASSIGNED
I can't reproduce this on Aurora (15.0a2).
I can reproduce with latest Nightly 16.0a1 (2012-07-12) on Galaxy S2 (Android 4.0.3) if that helps.
I can reproduce this on Aurora now.
Duplicate of this bug: 774097
I was having trouble reproducing this before because (unlike in bug 760087), this happens only when the highlighted match is a link.  So whether the bug occurs depends on the content.  It looks like this is not a new regression; it was just uncovered when bug 760087 was fixed.
Summary: Virtual keyboard is dismissed on first and successive matches in Find in Page → Virtual keyboard is dismissed when in Find in Page highlights a link
Attached patch patch (obsolete) — Splinter Review
GeckoInputConnection calls hideSoftInputFromWindow in response to reset messages from Gecko -- even if some other view like the Find In Page bar is in focus.  With this patch, it will hide the keyboard only if the Gecko view has the input focus.
Attachment #642743 - Flags: review?(cpeterson)
Attached patch patchSplinter Review
I uploaded the wrong patch, obviously.
Attachment #642743 - Attachment is obsolete: true
Attachment #642743 - Flags: review?(cpeterson)
Attachment #642748 - Flags: review?(cpeterson)
Comment on attachment 642748 [details] [diff] [review]
patch

Review of attachment 642748 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #642748 - Flags: review?(cpeterson) → review+
Comment on attachment 642748 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New Fx15 "Find In Page" feature (bug 695172)

User impact if declined: Find In Page is hard to use because the keyboard disappears unpredictably while you are typing.

Testing completed (on m-c, etc.): Landed on inbound 7/16.

Risk to taking this patch (and alternatives if risky): This is a very low-risk one line Android-only patch.  It just stops us from hiding the keyboard in one specific condition.

String or UUID changes made by this patch: None.

https://hg.mozilla.org/integration/mozilla-inbound/rev/93c10b4845d2
Attachment #642748 - Flags: approval-mozilla-beta?
Attachment #642748 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/93c10b4845d2
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 17
Comment on attachment 642748 [details] [diff] [review]
patch

[Triage Comment]
This is low risk and landing in plenty of time for verification.  Approving.
Attachment #642748 - Flags: approval-mozilla-beta?
Attachment #642748 - Flags: approval-mozilla-beta+
Attachment #642748 - Flags: approval-mozilla-aurora?
Attachment #642748 - Flags: approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.