Last Comment Bug 772057 - hidden symbol `vpx_codec_get_cx_data' isn't defined
: hidden symbol `vpx_codec_get_cx_data' isn't defined
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: WebRTC: Audio/Video (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla16
Assigned To: Takanori MATSUURA
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 06:52 PDT by Takanori MATSUURA
Modified: 2012-07-27 09:56 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix (1.42 KB, patch)
2012-07-09 07:58 PDT, Takanori MATSUURA
benjamin: review+
Details | Diff | Splinter Review

Description Takanori MATSUURA 2012-07-09 06:52:32 PDT
After enabling webRTC, m-c build  with system libvpx is failed during libxul.so generation.

/usr/bin/ld: libxul.so: hidden symbol `vpx_codec_get_cx_data' isn't defined
/usr/bin/ld: final link failed: Bad value
collect2: ld returned 1 exit status
make[5]: *** [libxul.so] Error 1

vpx_codec_get_cx_data seems to be defined at vpx_encoder.h and used at media/webrtc/trunk/src/modules/video_coding/codecs/vp8/main/source/vp8.cc.
Comment 1 Timothy B. Terriberry (:derf) 2012-07-09 07:00:36 PDT
What version of libvpx are you using?

What's the output of readelf -Ws on your libvpx .so?
Comment 2 Takanori MATSUURA 2012-07-09 07:58:38 PDT
Created attachment 640216 [details] [diff] [review]
Fix
Comment 3 Timothy B. Terriberry (:derf) 2012-07-10 10:52:16 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/a1ce3c30d47c
Comment 4 Takanori MATSUURA 2012-07-11 15:25:13 PDT
https://hg.mozilla.org/mozilla-central/rev/a1ce3c30d47c

Note You need to log in before you can comment on or make changes to this bug.