Crash Report [@ java.lang.OutOfMemoryError: at java.nio.ByteBuffer.put(ByteBuffer.java) ]

RESOLVED DUPLICATE of bug 766040

Status

()

--
critical
RESOLVED DUPLICATE of bug 766040
6 years ago
6 years ago

People

(Reporter: AdrianT, Unassigned)

Tracking

({crash})

16 Branch
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-00ac6979-06c3-487a-8723-dd56d2120709 .
============================================================= 
Issue occurred once. I had 5 tabs opened: about:home, google.com, news.google.com, cnn.com, planet.mozilla.org

Stack trace:
0 	libmozalloc.so 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:19
1 	libc.so 	__swrite 	
2 		@0x10003 	
3 	libdvm.so 	libdvm.so@0x171fe 	
4 	libc.so 	dlfree 	
5 	libc.so 	dlfree 	
6 		@0x4a0deb06 	
7 	libmozglue.so 	Java_org_mozilla_gecko_GeckoAppShell_reportJavaCrash 	mozglue/android/APKOpen.cpp:301
8 	libdvm.so 	libdvm.so@0x17076 	
9 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x22ed2a 	
10 	2 (deleted) 	2 @0x5b76e 	
11 	libdvm.so 	libdvm.so@0x1723e 	
12 	libdvm.so 	libdvm.so@0x457c5 	
13 	data@app@org.mozilla.fennec-1.apk@classes.dex 	data@app@org.mozilla.fennec-1.apk@classes.dex@0x12f7c3 	
14 	libmozglue.so 	Java_org_mozilla_gecko_GeckoAppShell_onChangeNetworkLinkStatus 	mozglue/android/APKOpen.cpp:300
15 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x22ed2a 	
16 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x22ed2a 	
17 	libdvm.so 	libdvm.so@0xa3446 	
18 	2 (deleted) 	2 @0x5b76e 	
19 	libmozglue.so 	Java_org_mozilla_gecko_GeckoAppShell_onChangeNetworkLinkStatus 	mozglue/android/APKOpen.cpp:300
20 	core.odex 	core.odex@0xe62c2 	
21 	data@app@org.mozilla.fennec-1.apk@classes.dex 	data@app@org.mozilla.fennec-1.apk@classes.dex@0x9689e 	
22 	2 (deleted) 	2 @0x5b76e 	
23 	libdvm.so 	libdvm.so@0x1bfe2 	
24 	libdvm.so 	libdvm.so@0xa3332 	
25 	libdvm.so 	libdvm.so@0xa7f4e 	
26 	libdvm.so 	libdvm.so@0x22c46 	
27 	libdvm.so 	libdvm.so@0x22bc6 	
28 	libdvm.so 	libdvm.so@0x21ae2 	
29 	libdvm.so 	libdvm.so@0x50d91 	
30 	data@app@org.mozilla.fennec-1.apk@classes.dex 	data@app@org.mozilla.fennec-1.apk@classes.dex@0x9805e 	
31 	2 (deleted) 	2 @0x1216d06 	
32 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x22d0ee 	
33 	libdvm.so 	libdvm.so@0x1bd26 	
34 	libdvm.so 	libdvm.so@0x1bd66 	
35 	libdvm.so 	libdvm.so@0x1bc46 	
36 	libdvm.so 	libdvm.so@0x1bc6e 	
37 	libdvm.so 	libdvm.so@0x1bc9e 	
38 	libdvm.so 	libdvm.so@0x1bcc2 	
39 	libdvm.so 	libdvm.so@0x7c203 	
40 	core.odex 	core.odex@0xe1b06 	
41 	core.odex 	core.odex@0xe1b06 	
42 	core.odex 	core.odex@0xe1bba 	
43 	libdvm.so 	libdvm.so@0x1bc9e 	
44 	libdvm.so 	libdvm.so@0x7c203 	
45 	data@app@org.mozilla.fennec-1.apk@classes.dex 	data@app@org.mozilla.fennec-1.apk@classes.dex@0xab286


Java Stack Trace:	

java.lang.OutOfMemoryError
	at java.nio.ByteBuffer.put(ByteBuffer.java:815)
	at org.mozilla.gecko.gfx.ScreenshotLayer$ScreenshotImage.copyBuffer(ScreenshotLayer.java:142)
	at org.mozilla.gecko.gfx.ScreenshotLayer$ScreenshotImage.setBitmap(ScreenshotLayer.java:148)
	at org.mozilla.gecko.gfx.ScreenshotLayer.setBitmap(ScreenshotLayer.java:54)
	at org.mozilla.gecko.gfx.LayerRenderer.setCheckerboardBitmap(LayerRenderer.java:138)
	at org.mozilla.gecko.ScreenshotHandler$1.run(GeckoAppShell.java:2460)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:144)
	at org.mozilla.gecko.GeckoBackgroundThread.run(GeckoBackgroundThread.java:31)
(Reporter)

Updated

6 years ago
Summary: crash in java → Crash Report [@ java.lang.OutOfMemoryError: at java.nio.ByteBuffer.put(ByteBuffer.java) ]

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 766040
You need to log in before you can comment on or make changes to this bug.