Last Comment Bug 772155 - Disallow nested content processes
: Disallow nested content processes
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: IPC (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: Justin Lebar (not reading bugmail)
:
: [PTO to Dec5] Bill McCloskey (:billm)
Mentors:
Depends on: 755001
Blocks: browser-api 756376 nested-oop nested-processes
  Show dependency treegraph
 
Reported: 2012-07-09 11:19 PDT by Justin Lebar (not reading bugmail)
Modified: 2014-06-19 01:57 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Bug 772155 - Disallow nested content processes. (1.06 KB, patch)
2012-07-09 11:30 PDT, Justin Lebar (not reading bugmail)
bzbarsky: review+
Details | Diff | Splinter Review

Description Justin Lebar (not reading bugmail) 2012-07-09 11:19:45 PDT
We don't support nested content processes at the moment (bug 761935).  But Gecko will happily create them.

Until they're supported, Gecko shouldn't try to create nested content processes.

This is important because it takes us closer to being able to remove the "remote" attribute on <iframe mozbrowser>.
Comment 1 Justin Lebar (not reading bugmail) 2012-07-09 11:30:48 PDT
Created attachment 640308 [details] [diff] [review]
Bug 772155 - Disallow nested content processes.
Comment 2 Justin Lebar (not reading bugmail) 2012-07-09 11:35:12 PDT
> This is important because it takes us closer to being able to remove the "remote" attribute on 
> <iframe mozbrowser>.

In particular, an app (loaded out of process) which contains <iframe mozbrowser> will, with this patch, automagically load that mozbrowser in-process.  Which is what we want.
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2012-07-09 14:57:15 PDT
Comment on attachment 640308 [details] [diff] [review]
Bug 772155 - Disallow nested content processes.

r=me
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-07-10 15:48:16 PDT
https://hg.mozilla.org/mozilla-central/rev/8e8bc0324383

Note You need to log in before you can comment on or make changes to this bug.