Last Comment Bug 772210 - Fix warning: unused variable 'initFlushCount'
: Fix warning: unused variable 'initFlushCount'
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: ARM Android
: -- minor (vote)
: mozilla16
Assigned To: Chris Peterson [:cpeterson]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 13:50 PDT by Chris Peterson [:cpeterson]
Modified: 2012-07-10 15:49 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
fix-initFlushCount-warning.patch (1.36 KB, patch)
2012-07-09 13:56 PDT, Chris Peterson [:cpeterson]
luke: review+
Details | Diff | Splinter Review

Description Chris Peterson [:cpeterson] 2012-07-09 13:50:59 PDT
When building for Android/JS_CPU_ARM, I see many instances of the following compiler warning because BaseAssembler.h is #included in many other files:

mozilla/inbound/js/src/methodjit/BaseAssembler.h: In member function 'JSC::AbstractMacroAssembler<JSC::ARMAssembler>::Call js::mjit::Assembler::callWithABI(void*, bool)':
mozilla/inbound/js/src/methodjit/BaseAssembler.h:563: warning: unused variable 'initFlushCount'
Comment 1 Chris Peterson [:cpeterson] 2012-07-09 13:56:29 PDT
Created attachment 640350 [details] [diff] [review]
fix-initFlushCount-warning.patch

Fix warning: unused variable 'initFlushCount' by using DebugOnly<int>. This code only affects #ifdef JS_CPU_ARM builds.
Comment 2 Chris Peterson [:cpeterson] 2012-07-09 14:16:48 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/c5623d48b5fc
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-07-09 17:30:00 PDT
Don't resolve bugs until they land on m-c.
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-07-10 15:49:42 PDT
https://hg.mozilla.org/mozilla-central/rev/c5623d48b5fc

Note You need to log in before you can comment on or make changes to this bug.