Last Comment Bug 772259 - Download history button shouldn't inherit the panel's background
: Download history button shouldn't inherit the panel's background
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Downloads Panel (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 16
Assigned To: Dão Gottwald [:dao]
:
Mentors:
Depends on:
Blocks: DownloadsPanel
  Show dependency treegraph
 
Reported: 2012-07-09 15:40 PDT by Dão Gottwald [:dao]
Modified: 2012-07-10 15:46 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.81 KB, patch)
2012-07-09 15:40 PDT, Dão Gottwald [:dao]
paolo.mozmail: review+
Details | Diff | Splinter Review

Description Dão Gottwald [:dao] 2012-07-09 15:40:42 PDT
Created attachment 640391 [details] [diff] [review]
patch

The button inheriting the panel's background doesn't seem to make sense. For solid colors it doesn't make a difference and for background images it causes strange and unintended effects, as currently on Windows.
Comment 1 :Paolo Amadini 2012-07-10 01:20:24 PDT
Comment on attachment 640391 [details] [diff] [review]
patch

Makes a lot of sense, thanks for finding this!
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-07-10 15:46:09 PDT
https://hg.mozilla.org/mozilla-central/rev/e8dc86da1363

Note You need to log in before you can comment on or make changes to this bug.