Last Comment Bug 772285 - rm JSPD_ARGUMENT/JSPD_VARIABLE
: rm JSPD_ARGUMENT/JSPD_VARIABLE
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: general
:
Mentors:
Depends on:
Blocks: 767013
  Show dependency treegraph
 
Reported: 2012-07-09 16:45 PDT by Luke Wagner [:luke]
Modified: 2012-07-30 00:06 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
rm (14.34 KB, patch)
2012-07-09 16:45 PDT, Luke Wagner [:luke]
sphink: review+
odvarko: feedback+
Details | Diff | Splinter Review

Description Luke Wagner [:luke] 2012-07-09 16:45:40 PDT
Created attachment 640426 [details] [diff] [review]
rm

These flags ultimately aren't necessary since I can't find any uses of jsdIProperty.varArgSlot in firebug.  Firebug seems to run fine and show locals in the watch pane; is there anything I'm missing Jan?
Comment 1 Steve Fink [:sfink] [:s:] 2012-07-10 09:28:43 PDT
Comment on attachment 640426 [details] [diff] [review]
rm

Review of attachment 640426 [details] [diff] [review]:
-----------------------------------------------------------------

This patch also removes FLAG_ARGUMENT and FLAG_VARIABLE, neither of which seems to show up in the Firebug source either.

::: js/jsd/idl/jsdIDebuggerService.idl
@@ -1250,5 @@
>      readonly attribute jsdIValue     name;
>      /** value of this property. */
>      readonly attribute jsdIValue     value;
> -    /** slot number if this property is a local variable or parameter. */
> -    readonly attribute unsigned long varArgSlot;

You need to bump the interface uuid.
Comment 2 Luke Wagner [:luke] 2012-07-10 17:51:40 PDT
(In reply to Steve Fink [:sfink] from comment #1)
Good catch, thanks!

https://hg.mozilla.org/integration/mozilla-inbound/rev/b036556db80a
Comment 3 Ed Morley [:emorley] 2012-07-11 09:32:26 PDT
https://hg.mozilla.org/mozilla-central/rev/b036556db80a
Comment 4 Jan Honza Odvarko [:Honza] 2012-07-30 00:06:55 PDT
Comment on attachment 640426 [details] [diff] [review]
rm

(sorry for the delay, just got back from vacation)

I don't see any troubles in Firebug caused by this patch.

Honza

Note You need to log in before you can comment on or make changes to this bug.