Last Comment Bug 772296 - 3D animation text disappears during animation
: 3D animation text disappears during animation
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: 15 Branch
: x86 Windows 7
: -- normal (vote)
: mozilla17
Assigned To: Matt Woodrow (:mattwoodrow)
: juan becerra [:juanb]
:
Mentors:
http://www.starbase-alpha.com/
Depends on:
Blocks: 722603 771180
  Show dependency treegraph
 
Reported: 2012-07-09 17:13 PDT by Alice0775 White
Modified: 2012-08-03 08:24 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
wontfix
+
fixed


Attachments
testcase.html (1.70 KB, text/html)
2012-07-09 17:13 PDT, Alice0775 White
no flags Details
Forward transform the overflow rect (3.08 KB, patch)
2012-07-25 16:19 PDT, Matt Woodrow (:mattwoodrow)
roc: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review
Reduced test case (759 bytes, text/html)
2012-07-25 16:20 PDT, Matt Woodrow (:mattwoodrow)
no flags Details

Description Alice0775 White 2012-07-09 17:13:40 PDT
Created attachment 640445 [details]
testcase.html

Build Identifier:
http://hg.mozilla.org/releases/mozilla-aurora/rev/a45c99cca5e5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120709 Firefox/15.0a2 ID:20120709042008

Spun off from Bug 771180.

Steps to Reproduce:
1. Prepare a new profile
2. Open URL or testcase.html
   -- observe 3d text

Actual Results:
 3D animation text disappears during animation

Expected Results:
 Should not
Comment 1 Alice0775 White 2012-07-09 17:14:57 PDT
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/1e2b674b6ba9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120511112347
Bad:
http://hg.mozilla.org/mozilla-central/rev/176f396a1293
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120511113950
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1e2b674b6ba9&tochange=176f396a1293

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b9c3d700625a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120510191731
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/15d1960c419e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120511004931
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b9c3d700625a&tochange=15d1960c419e

Triggered by: 287dc7b3152b	Matt Woodrow — Bug 722603 - Improve dirty rect calculation with 3d transforms and preserve-3d. r=roc
Comment 2 Willie Meier 2012-07-19 08:50:04 PDT
This appears now in FF15, FF16 and FF17 where as it does not in FF13 or FF14.

any news on this?
Comment 3 Matt Woodrow (:mattwoodrow) 2012-07-25 16:19:39 PDT
Created attachment 645927 [details] [diff] [review]
Forward transform the overflow rect

We already used this code for Preserve3D(), I'm not sure why it was ever limited to that, since the same problem exists for both paths.
Comment 4 Matt Woodrow (:mattwoodrow) 2012-07-25 16:20:05 PDT
Created attachment 645928 [details]
Reduced test case
Comment 5 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-07-25 16:54:44 PDT
Comment on attachment 645927 [details] [diff] [review]
Forward transform the overflow rect

Review of attachment 645927 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/generic/nsFrame.cpp
@@ +1779,5 @@
>        dirtyRect = GetVisualOverflowRectRelativeToSelf();
>      } else {
> +      // Trying to  back-transform arbitrary rects gives us really weird results. I believe 
> +      // this is from points that lie beyond the vanishing point. As a workaround we transform t
> +      // he overflow rect into screen space and compare in that coordinate system.

Fix line break in "t he"
Comment 6 Matt Woodrow (:mattwoodrow) 2012-07-25 21:34:06 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/5ee7f05cfeff
Comment 7 Ed Morley [:emorley] 2012-07-26 05:07:43 PDT
https://hg.mozilla.org/mozilla-central/rev/5ee7f05cfeff
Comment 8 Willie Meier 2012-07-28 17:36:19 PDT
(In reply to Ed Morley [:edmorley] from comment #7)
> https://hg.mozilla.org/mozilla-central/rev/5ee7f05cfeff

Am I correct understanding that this fix for the bug will not appear until FF17?
which IMHO doesn't make sense as it occurs in FF15 and FF16 as well.

Now since the bug doesn't present itself in FF14 one would while it does in 15, 16 one have to wait til FF17 is released

IMHO it isn't resolved or fixed when 15 ans 16 are still affected by the bug
Comment 9 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-07-28 20:48:12 PDT
Comment on attachment 645927 [details] [diff] [review]
Forward transform the overflow rect

Review of attachment 645927 [details] [diff] [review]:
-----------------------------------------------------------------

I think we should take this on Aurora, since we're unprefixing CSS transforms there and the patch is pretty safe (doesn't introduce any new code paths).

I don't think we need to take this on Beta though.
Comment 10 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-07-28 20:49:09 PDT
(In reply to Willie Meier from comment #8)
> Am I correct understanding that this fix for the bug will not appear until
> FF17?
> which IMHO doesn't make sense as it occurs in FF15 and FF16 as well.

If it gets approved for Aurora it will appear in FF16.

> IMHO it isn't resolved or fixed when 15 ans 16 are still affected by the bug

RESOLVED FIXED means fixed in nightly builds. That is how our process works.
Comment 11 Alex Keybl [:akeybl] 2012-07-30 12:48:51 PDT
Comment on attachment 645927 [details] [diff] [review]
Forward transform the overflow rect

[Triage Comment]
Firefox 15 regression, but we don't expect this to have significant impact in that version. Approving for Aurora 16, where we've done a lot of CSS unprefixing.
Comment 12 Matt Woodrow (:mattwoodrow) 2012-07-30 17:54:05 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/7934b72dae25
Comment 13 Willie Meier 2012-07-31 15:06:58 PDT
(In reply to Alice0775 White from comment #13)
> Created attachment 640445 [details]
> testcase.html
> 
> Build Identifier:
> http://hg.mozilla.org/releases/mozilla-aurora/rev/a45c99cca5e5
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120709 Firefox/15.0a2
> ID:20120709042008
> 
> Spun off from Bug 771180.
> 
> Steps to Reproduce:
> 1. Prepare a new profile
> 2. Open URL or testcase.html
>    -- observe 3d text
> 
> Actual Results:
>  3D animation text disappears during animation
> 
> Expected Results:
>  Should not

IMHO, it isn't fixed referring to FF16, FF17 as stated.

May I suggest that you visit www.starbase-alpha.com with FF14 then run FF16 and then run FF17 you'll notice the difference.  The behavior of FF16/FF17 is similar or identical.

FF16/FF17 are partially fixed yet its behavior is not that of FF14.  The flow is quite different between FF14 and 16/17

Has something else changed that I am not aware as it relates to the specs?

The base ref is FF14.0.1 as something must have changed which which appears to have been carried over to the other versions 15, 16,17.
Would not fixing 15 first which is the next release and then apply to 16 and 17 makes logical sense to me(fix the start rather than the end or middle).

This issue does/did not happen in Chrome/Safari
Comment 14 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-08-02 20:28:29 PDT
(In reply to Willie Meier from comment #13)
> May I suggest that you visit www.starbase-alpha.com with FF14 then run FF16
> and then run FF17 you'll notice the difference.  The behavior of FF16/FF17
> is similar or identical.
> 
> FF16/FF17 are partially fixed yet its behavior is not that of FF14.  The
> flow is quite different between FF14 and 16/17

That site looks identical in Nightly (FF17) and Chrome, to me. If you think there is something wrong with Nightly's behavior, please file a new bug for that.
Comment 15 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-03 08:24:22 PDT
Removing tracking for 15, setting to wontfix since we're not landing this to Beta.

Note You need to log in before you can comment on or make changes to this bug.