Enable Opus support by default

RESOLVED FIXED in Firefox 15

Status

()

Core
Audio/Video
RESOLVED FIXED
5 years ago
5 months ago

People

(Reporter: derf, Assigned: derf)

Tracking

(Depends on: 1 bug, {relnote})

15 Branch
mozilla16
relnote
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox15+ fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
The support for the Opus codec added in bug 674225 was hidden behind a preference in case there were any last-minute changes to the format during the final phases of standardization at the IETF. It has now been approved by the IESG, so this is no longer a danger. We should flip the preference to enable support by default.
(Assignee)

Comment 1

5 years ago
Created attachment 640501 [details] [diff] [review]
Enable Opus support by default
Assignee: nobody → tterribe
Status: NEW → ASSIGNED
Attachment #640501 - Flags: review?(roc)

Comment 2

5 years ago
Is this intended to land on Fx 15? Otherwise might need documentation changes.
Blocks: 674225
Keywords: dev-doc-needed
(Assignee)

Comment 3

5 years ago
Yes, after getting review I was planning to ask for aurora approval.
Attachment #640501 - Flags: review?(roc) → review+
(Assignee)

Comment 4

5 years ago
Comment on attachment 640501 [details] [diff] [review]
Enable Opus support by default

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 674225
User impact if declined: Opus support will remain behind a pref and thus be unavailable to most users (hindering adoption by websites). Flipping this pref now means we will be shipping it to users right about the same time the final RFC comes out, so we should be able to build on momentum around that event. Holding off until the next release means missing out on that.
Testing completed (on m-c, etc.): The codec library itself has undergone extensive testing (see http://www.ietf.org/proceedings/82/slides/codec-4.pdf for just a brief summary). The version we imported and the code we wrote to hook it into Firefox has been fuzz-tested (bug 750714), and has been shipping in Nightlies and on Aurora (behind this pref) since May 4th. Bug 674225 added a set of media tests for Opus, and a try run with this pref flipped (enabling them) is relatively greenish: https://tbpl.mozilla.org/?tree=Try&rev=2db55b1f5180
Risk to taking this patch (and alternatives if risky): Low. No code changes. This should not impact any existing features.
String or UUID changes made by this patch: None.
Attachment #640501 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/24970e96b3de
Target Milestone: --- → mozilla16
https://hg.mozilla.org/mozilla-central/rev/24970e96b3de
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
status-firefox15: --- → affected
tracking-firefox15: --- → +
Keywords: relnote

Comment 7

5 years ago
Asa - any non-engineering reasons to hold off on uplift of having Opus enabled by default? I can't think of any, but want to be sure.

Comment 8

5 years ago
Comment on attachment 640501 [details] [diff] [review]
Enable Opus support by default

[Triage Comment]
Spoke with Asa. This has the green light. Please land on mozilla-aurora ASAP to make the next merge on Monday.
Attachment #640501 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 9

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/c2541e0e2898
status-firefox15: affected → fixed

Comment 10

5 years ago
removing dev-doc-needed, no changes required after landing on aurora
Keywords: dev-doc-needed
Restoring dev-doc-needed. Opus is mentioned on the codec support page and in the release notes. However, the line,

", although support is only available if you set the media.opus.enabled preference to true"

should be removed from https://developer.mozilla.org/En/Media_formats_supported_by_the_audio_and_video_elements#Ogg_Opus now that this bug has landed. Wiki edits are currently disabled for the kuma migration, so we need a reminder to do this later.
Keywords: dev-doc-needed

Comment 12

5 years ago
> https://developer.mozilla.org/en/Media_formats_supported_by_the_audio_and_video_elements#Ogg_Opus 
oops, looked only at the browser compatibility table.

Also: Heading structure should change to:
== Ogg
=== Ogg Ogg Theora Vorbis
=== Ogg Opus

and https://developer.mozilla.org/en/Firefox_15_for_developers
could link into #Ogg_Opus

Comment 13

5 years ago
It should be in http://www.mozilla.org/firefox/15.0beta/releasenotes/ and http://www.mozilla.org/mobile/15.0beta/releasenotes/ instead of http://www.mozilla.org/firefox/16.0a2/auroranotes/ and http://www.mozilla.org/mobile/16.0a2/auroranotes/.
I've removed the user pref reference now that the wiki is open for editing again, but left the section headers as is. Either way, linking to 

  https://developer.mozilla.org/en-US/docs/Media_formats_supported_by_the_audio_and_video_elements#Ogg_Opus

will work fine.
Keywords: dev-doc-needed
Depends on: 1129355
Depends on: 976488
Depends on: 935617
You need to log in before you can comment on or make changes to this bug.