Last Comment Bug 772570 - Build failure: Cannot open include file: 'vpx/vpx_encoder.h' @ reference_picture_selection.cc
: Build failure: Cannot open include file: 'vpx/vpx_encoder.h' @ reference_pict...
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: WebRTC: Audio/Video (show other bugs)
: Trunk
: x86_64 Windows 7
: -- blocker (vote)
: mozilla17
Assigned To: [:jesup] on pto until 2016/7/5 Randell Jesup
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 11:29 PDT by Honza Bambas (:mayhemer)
Modified: 2012-08-05 08:18 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
untangle MOZ_WEBM from MOZ_VP8 so we can disable webm with webrtc enabled (1.23 KB, patch)
2012-07-10 13:40 PDT, [:jesup] on pto until 2016/7/5 Randell Jesup
no flags Details | Diff | Review
untangle MOZ_WEBM from MOZ_VP8 so we can disable webm with webrtc enabled (updated) (1.80 KB, patch)
2012-07-10 14:02 PDT, [:jesup] on pto until 2016/7/5 Randell Jesup
tterribe: review+
ted: review+
Details | Diff | Review

Description Honza Bambas (:mayhemer) 2012-07-10 11:29:42 PDT
Windows 7, VC10, pymake.

.mozconfig:

# Options for client.mk.
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/_obj-browser-debug
mk_add_options MOZ_MAKE_FLAGS=-j9

# Options for 'configure' (same as command-line options).
#ac_add_options --enable-jemalloc

export MOZ_DEBUG_SYMBOLS=1

ac_add_options --enable-application=browser
ac_add_options --enable-debug
ac_add_options --disable-optimize
ac_add_options --enable-shared
ac_add_options --disable-static
ac_add_options --enable-tests
ac_add_options --enable-logging
ac_add_options --enable-visual-event-tracer
ac_add_options --disable-installer
ac_add_options --enable-chrome-format=flat
ac_add_options --disable-crashreporter
ac_add_options --disable-webm           # <<<<< notice this option please
ac_add_options --disable-accessibility
ac_add_options --disable-angle


system-libvpx has no effect on win.
adding --disable-webrtc works the problem around, but that is just a short term option since I will soon need to build webrt on my machine.


Complete command:

c:\Mozilla\src\mozilla-central\config\rules.mk:1021:0$ c:/Mozilla/src/mozilla-central/_obj-browser-debug/_virtualenv/Scripts/python.exe -O ../../../../../../.
./build/cl.py cl -Fovideo_coding/codecs/vp8/main/source/reference_picture_selection.obj -c   -D_WIN32_WINNT=0x0601 -DWINVER=0x0601 -DWIN32 -D_WINDOWS -DNOMINM
AX -DPSAPI_VERSION=1 -D_CRT_RAND_S -DCERT_CHAIN_PARA_HAS_EXTRA_FIELDS -DWIN32_LEAN_AND_MEAN -D_ATL_NO_OPENGL -D_HAS_TR1=0 -D_HAS_EXCEPTIONS=0 -D_SECURE_ATL -D
CHROMIUM_BUILD -DTOOLKIT_VIEWS=1 -DENABLE_REMOTING=1 -DENABLE_P2P_APIS=1 -DENABLE_CONFIGURATION_POLICY -DENABLE_INPUT_SPEECH -DENABLE_NOTIFICATIONS -DENABLE_G
PU=1 -DENABLE_EGLIMAGE=1 -DUSE_SKIA=1 -D__STD_C -D_CRT_SECURE_NO_DEPRECATE -D_SCL_SECURE_NO_DEPRECATE -DENABLE_REGISTER_PROTOCOL_HANDLER=1 -DENABLE_WEB_INTENT
S=1 -DENABLE_PLUGIN_INSTALLATION=1 -DWEBRTC_WIN -DWEBRTC_EXPORT -DWEBRTC_LIBVPX_VERSION=971 -DWEBRTC_LIBVPX_TEMPORAL_LAYERS=0 -D__STDC_FORMAT_MACROS -DDYNAMIC
_ANNOTATIONS_ENABLED=1 -DWTF_USE_DYNAMIC_ANNOTATIONS=1 -DUNICODE -D_UNICODE -I. -I../../../../../../../media/webrtc/trunk/src/modules/.. -I../../../../../../.
./media/webrtc/trunk/src/modules/../.. -I../../../../../../../media/webrtc/trunk/src/modules/../../third_party/wtl/include -I../../../../../../../media/webrtc
/trunk/src/modules/video_coding/codecs/vp8/main/interface -I../../../../../../../media/webrtc/trunk/src/modules/../../src/common_video/interface -I../../../..
/../../../media/webrtc/trunk/src/modules/../../src/modules/video_coding/codecs/interface -I../../../../../../../media/webrtc/trunk/src/modules/../../src/modul
es/interface -I../../../../../../dist/include -I../../../../../../../media/webrtc/trunk/src/modules/../system_wrappers/interface -I"/include"    -TP -nologo -
W3 -Gy -Fdgenerated.pdb -wd4800 -we4553 -GR- -DDEBUG -D_DEBUG -DTRACING -Zi -Oy-   -MDd           -FI ../../../../../../dist/include/mozilla-config.h -DMOZILL
A_CLIENT c:/Mozilla/src/mozilla-central/_obj-browser-debug/media/webrtc/trunk/src/modules/modules_webrtc_vp8/../../../../../../../media/webrtc/trunk/src/modul
es/video_coding/codecs/vp8/main/source/reference_picture_selection.cc
reference_picture_selection.cc
c:\Mozilla\src\mozilla-central\_obj-browser-debug\media\webrtc\trunk\src\modules\modules_webrtc_vp8\../../../../../../dist/include/mozilla-config.h(98) : warn
ing C4005: 'WINVER' : macro redefinition
        command-line arguments :  see previous definition of 'WINVER'
c:\Mozilla\src\mozilla-central\_obj-browser-debug\media\webrtc\trunk\src\modules\modules_webrtc_vp8\../../../../../../dist/include/mozilla-config.h(105) : war
ning C4005: '_WIN32_WINNT' : macro redefinition
        command-line arguments :  see previous definition of '_WIN32_WINNT'
c:/Mozilla/src/mozilla-central/_obj-browser-debug/media/webrtc/trunk/src/modules/modules_webrtc_vp8/../../../../../../../media/webrtc/trunk/src/modules/video_
coding/codecs/vp8/main/source/reference_picture_selection.cc(14) : fatal error C1083: Cannot open include file: 'vpx/vpx_encoder.h': No such file or directory
Comment 1 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-10 12:01:40 PDT
Probably a configure.in issue between the two options
Comment 2 Timothy B. Terriberry (:derf) 2012-07-10 12:57:27 PDT
(In reply to Randell Jesup [:jesup] from comment #1)
> Probably a configure.in issue between the two options

I don't think it's configure.in that's the problem, but toolkit/toolkit-makefiles.sh and toolkit/toolkit-tiers.mk. Both of those add media/libvpx things to the build behind a MOZ_WEBM flag instead of a MOZ_VP8 flag. layout/media/symbols.def.in has a similar problem.
Comment 3 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-10 13:29:24 PDT
Ok, thanks.  Just did a full build with the options given (on Linux!) and it was fine....
Comment 4 Honza Bambas (:mayhemer) 2012-07-10 13:32:46 PDT
I believe this this just related to Windows.  How do we build on the production build machines?  Looks like I should install VP8 support for win and make it available to the moz build config.
Comment 5 Timothy B. Terriberry (:derf) 2012-07-10 13:34:57 PDT
(In reply to Honza Bambas (:mayhemer) from comment #4)
> I believe this this just related to Windows.  How do we build on the
> production build machines?  Looks like I should install VP8 support for win
> and make it available to the moz build config.

We should _not_ be pulling in system libvpx by default. We should be using the in-tree copy.
Comment 6 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-10 13:40:35 PDT
Created attachment 640761 [details] [diff] [review]
untangle MOZ_WEBM from MOZ_VP8 so we can disable webm with webrtc enabled
Comment 7 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-10 14:02:11 PDT
Created attachment 640771 [details] [diff] [review]
untangle MOZ_WEBM from MOZ_VP8 so we can disable webm with webrtc enabled (updated)
Comment 8 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-10 14:03:18 PDT
Honza: please give either of these a try.  (The update won't actually change your result).
Comment 9 Honza Bambas (:mayhemer) 2012-07-10 14:08:01 PDT
I'll try probably tomorrow.  Thanks for quick reaction, though.
Comment 10 Honza Bambas (:mayhemer) 2012-07-12 05:13:13 PDT
Comment on attachment 640771 [details] [diff] [review]
untangle MOZ_WEBM from MOZ_VP8 so we can disable webm with webrtc enabled (updated)

So, I've removed --disable-webrtc from my mozconfig and with this patch I can build.  Thanks for a quick fix!
Comment 11 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-12 07:58:02 PDT
Comment on attachment 640771 [details] [diff] [review]
untangle MOZ_WEBM from MOZ_VP8 so we can disable webm with webrtc enabled (updated)

Checking with ted if this needs build peer review too
Comment 12 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-13 08:08:39 PDT
Comment on attachment 640771 [details] [diff] [review]
untangle MOZ_WEBM from MOZ_VP8 so we can disable webm with webrtc enabled (updated)

Since ted said on IRC he'd need to look to know if it needs build system peer review, asking for review.
Comment 13 Honza Bambas (:mayhemer) 2012-07-21 14:06:23 PDT
Ted, any chance to move forward here?  I have to apply this patch on all platforms I build on.  Thanks.
Comment 14 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-27 10:17:11 PDT
Sorry, was traveling

https://hg.mozilla.org/integration/mozilla-inbound/rev/d2561fcf4882
Comment 15 Ryan VanderMeulen [:RyanVM] 2012-07-28 18:38:04 PDT
https://hg.mozilla.org/mozilla-central/rev/d2561fcf4882

Note You need to log in before you can comment on or make changes to this bug.