Last Comment Bug 772630 - JS Profile feature crash if used on startup
: JS Profile feature crash if used on startup
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Gecko Profiler (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla16
Assigned To: Benoit Girard (:BenWa)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 13:43 PDT by Benoit Girard (:BenWa)
Modified: 2012-07-11 09:31 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Delay JS profiling until we have a runtime (3.18 KB, patch)
2012-07-10 13:45 PDT, Benoit Girard (:BenWa)
u443197: review+
ehsan: review+
Details | Diff | Splinter Review

Description Benoit Girard (:BenWa) 2012-07-10 13:43:37 PDT
If we try to call 'js::SetRuntimeProfilingStack' before we have a JS runtime and before the JS engine is started and we crash. We start profiling on start up in mobile since we use an environment variable to start.

Simple fix is to delay profiling until we get a runtime.
Comment 1 Benoit Girard (:BenWa) 2012-07-10 13:45:24 PDT
Created attachment 640764 [details] [diff] [review]
Delay JS profiling until we have a runtime

Also use JS profiling by default on mobile.
Comment 3 Ed Morley [:emorley] 2012-07-11 09:31:46 PDT
https://hg.mozilla.org/mozilla-central/rev/506be1161172

Note You need to log in before you can comment on or make changes to this bug.