Show a throbber when we're doing network activity

RESOLVED WONTFIX

Status

()

Firefox for Android
Web Apps
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: wesj, Unassigned)

Tracking

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(fennec-)

Details

(Reporter)

Description

6 years ago
This might just be the fault of apps, but I often find I tap on an in-app link and think nothing happened. A few seconds later the new page appears. Maybe we should show a throbber when we hit the network? Something small in the corner to let the user know we're thinking.

Maybe we can not show it for things in the app cache.

Updated

6 years ago
tracking-fennec: --- → ?

Updated

6 years ago
OS: Linux → Android
Hardware: x86 → ARM
IMO the webapp should be handling should be handling this themselves. Please renom if there is a good reason for us to handle that for them.
tracking-fennec: ? → -
(Reporter)

Comment 2

6 years ago
I agree. Pages like Yelp and Facebook manage to show their own throbbers and I wouldn't want to taint their good experience to fix other people's bad ones. I'm not sure there's a good solution here....
(In reply to Wesley Johnston (:wesj) from comment #2)
> I agree. Pages like Yelp and Facebook manage to show their own throbbers and
> I wouldn't want to taint their good experience to fix other people's bad
> ones. I'm not sure there's a good solution here....

The only argument I could see possibly for making this important is if B2G is doing this already by default. Tony - Do you know?
Looking at B2G's implementation, they do end up showing a progress bar at the top to indicate when the web app is loading or not. So this sounds like this is a valid bug, the question is how important is it from the UX side of the world.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX

Comment 5

6 years ago
We are not going to show progress bars for apps and instead let app developers support this on their own.

For improving app start up, we will work on the appcache fixes that have already landed for desktop, push for developer adoption, measure and propose next steps, as appropriate.
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: WONTFIX → ---

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 785492
You need to log in before you can comment on or make changes to this bug.