Last Comment Bug 772801 - B2G Wifi: Fix wifi scanning on ICS
: B2G Wifi: Fix wifi scanning on ICS
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Hardware Abstraction Layer (HAL) (show other bugs)
: Trunk
: ARM Gonk (Firefox OS)
: -- critical (vote)
: ---
Assigned To: Blake Kaplan (:mrbkap) (PTO until Jan. 2, 2017)
:
:
Mentors:
Depends on: 774876
Blocks: b2g-wifi
  Show dependency treegraph
 
Reported: 2012-07-11 05:11 PDT by Vincent Chang[:vchang][changyihsin]
Modified: 2012-08-15 10:14 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+


Attachments
WIP (91 bytes, patch)
2012-07-11 05:11 PDT, Vincent Chang[:vchang][changyihsin]
no flags Details | Diff | Splinter Review
WIP (896 bytes, patch)
2012-07-11 05:16 PDT, Vincent Chang[:vchang][changyihsin]
no flags Details | Diff | Splinter Review
wpa_supplicant.conf (242 bytes, text/plain)
2012-07-11 05:17 PDT, Vincent Chang[:vchang][changyihsin]
no flags Details
Cleaner patch (1.41 KB, patch)
2012-07-12 15:38 PDT, Blake Kaplan (:mrbkap) (PTO until Jan. 2, 2017)
mwu.code: review+
mrbkap: checkin+
Details | Diff | Splinter Review
Followup (1.03 KB, patch)
2012-07-12 18:54 PDT, Blake Kaplan (:mrbkap) (PTO until Jan. 2, 2017)
no flags Details | Diff | Splinter Review

Description Vincent Chang[:vchang][changyihsin] 2012-07-11 05:11:01 PDT
Created attachment 641009 [details] [diff] [review]
WIP

Wifi scanning on ICS is broken for Otoro devices.
Comment 1 Vincent Chang[:vchang][changyihsin] 2012-07-11 05:16:21 PDT
Created attachment 641014 [details] [diff] [review]
WIP
Comment 2 Vincent Chang[:vchang][changyihsin] 2012-07-11 05:17:56 PDT
Created attachment 641015 [details]
wpa_supplicant.conf

replaced /data/misc/wifi/wpa_supplicant.conf
Comment 3 John Hammink 2012-07-12 10:04:02 PDT
We're currently blocked on testing due to this.  Here's the related gaia issue:
https://github.com/mozilla-b2g/gaia/issues/2361 - [settings] Wifi scans but does not present list of SSIDs
Comment 4 Blake Kaplan (:mrbkap) (PTO until Jan. 2, 2017) 2012-07-12 15:06:37 PDT
Comment on attachment 641014 [details] [diff] [review]
WIP

This is the right approach. I have a cleaned-up patch as well.
Comment 5 Blake Kaplan (:mrbkap) (PTO until Jan. 2, 2017) 2012-07-12 15:38:11 PDT
Created attachment 641633 [details] [diff] [review]
Cleaner patch
Comment 6 Blake Kaplan (:mrbkap) (PTO until Jan. 2, 2017) 2012-07-12 18:47:58 PDT
Comment on attachment 641633 [details] [diff] [review]
Cleaner patch

https://hg.mozilla.org/mozilla-central/rev/32c911bc2579
Comment 7 Blake Kaplan (:mrbkap) (PTO until Jan. 2, 2017) 2012-07-12 18:54:16 PDT
Created attachment 641689 [details] [diff] [review]
Followup

mwu, I hope you don't mind reviewing this... basically this patch lets us not do the active/passive scanning stuff if the driver doesn't support it.
Comment 8 Michael Wu [:mwu] 2012-07-12 19:27:25 PDT
Comment on attachment 641689 [details] [diff] [review]
Followup

Not true - passive scans are fully supported with a nl80211 driver. wpa_supplicant just isn't exposing an interface to do it, and why should it? An active scan is what you want 98% of the time. WifiWorker.js probably shouldn't care about scan modes at all.
Comment 9 Tony Chung [:tchung] 2012-07-16 11:30:38 PDT
flagging blocking-basecamp
Comment 10 Tony Chung [:tchung] 2012-07-17 13:48:34 PDT
This is still reproducible on a daily otoro build of 7-17-2012.   

REpro:
1) load settings > wifi
2) uncheck the wifi checkbox  (assuming you had networks found before)
3) recheck the wifi checkbox
4) Verify no networks are ever scanned or found again.
Comment 11 Michael Wu [:mwu] 2012-07-17 13:51:00 PDT
(In reply to Tony Chung [:tchung] from comment #10)
> This is still reproducible on a daily otoro build of 7-17-2012.   
> 
> REpro:
> 1) load settings > wifi
> 2) uncheck the wifi checkbox  (assuming you had networks found before)
> 3) recheck the wifi checkbox
> 4) Verify no networks are ever scanned or found again.

That is a different issue.
Comment 12 Dietrich Ayala (:dietrich) 2012-07-17 14:08:41 PDT
Tony, don't be a flag-clearer! ;)
Comment 13 Tony Chung [:tchung] 2012-07-17 15:44:03 PDT
(In reply to Michael Wu [:mwu] from comment #11)
> (In reply to Tony Chung [:tchung] from comment #10)
> > This is still reproducible on a daily otoro build of 7-17-2012.   
> > 
> > REpro:
> > 1) load settings > wifi
> > 2) uncheck the wifi checkbox  (assuming you had networks found before)
> > 3) recheck the wifi checkbox
> > 4) Verify no networks are ever scanned or found again.
> 
> That is a different issue.

okay, i filed https://bugzilla.mozilla.org/show_bug.cgi?id=774876 to track this.
Comment 14 Gene Lian [:gene] (I already quit Mozilla) 2012-08-11 00:40:54 PDT
Does this one look like a duplicate issue by Bug 782020 I just fired?
Comment 15 Michael Wu [:mwu] 2012-08-15 10:14:57 PDT
Resolving this bug since the main issue is already fixed. I don't think we really need the follow up so I've cleared review, but we can do that in another bug if you think that check should be there.

Note You need to log in before you can comment on or make changes to this bug.