Last Comment Bug 772993 - Compiler warnings in widget/android
: Compiler warnings in widget/android
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget: Android (show other bugs)
: unspecified
: All Android
: -- normal (vote)
: mozilla16
Assigned To: Kartikaya Gupta (email:kats@mozilla.com)
:
: Jim Chen [:jchen] [:darchons]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 12:39 PDT by Kartikaya Gupta (email:kats@mozilla.com)
Modified: 2012-07-12 17:52 PDT (History)
1 user (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (8.67 KB, patch)
2012-07-11 12:52 PDT, Kartikaya Gupta (email:kats@mozilla.com)
cpeterson: review+
Details | Diff | Splinter Review

Description Kartikaya Gupta (email:kats@mozilla.com) 2012-07-11 12:39:27 PDT
/home/kats/zspace/mozilla-git/widget/android/AndroidJavaWrappers.cpp: In member function 'void mozilla::AndroidGeckoEvent::ReadPointArray(nsTArray<nsIntPoint>&, JNIEnv*, _jfieldID*, PRUint32)':
/home/kats/zspace/mozilla-git/widget/android/AndroidJavaWrappers.cpp:310: warning: comparison between signed and unsigned integer expressions
/home/kats/zspace/mozilla-git/widget/android/AndroidJavaWrappers.cpp: In member function 'void mozilla::AndroidGeckoEvent::ReadIntArray(nsTArray<int>&, JNIEnv*, _jfieldID*, PRUint32)':
/home/kats/zspace/mozilla-git/widget/android/AndroidJavaWrappers.cpp:327: warning: comparison between signed and unsigned integer expressions
/home/kats/zspace/mozilla-git/widget/android/AndroidJavaWrappers.cpp: In member function 'void mozilla::AndroidGeckoEvent::ReadFloatArray(nsTArray<float>&, JNIEnv*, _jfieldID*, PRUint32)':
/home/kats/zspace/mozilla-git/widget/android/AndroidJavaWrappers.cpp:341: warning: comparison between signed and unsigned integer expressions


/home/kats/zspace/mozilla-git/widget/android/nsAppShell.cpp: In constructor 'ScreenshotRunnable::ScreenshotRunnable(nsIAndroidBrowserApp*, int, nsTArray<nsIntPoint>&, int, mozilla::RefCountedJavaObject*)':
/home/kats/zspace/mozilla-git/widget/android/nsAppShell.cpp:94: warning: 'ScreenshotRunnable::mTabId' will be initialized after
/home/kats/zspace/mozilla-git/widget/android/nsAppShell.cpp:93: warning:   'nsTArray<nsIntPoint> ScreenshotRunnable::mPoints'
/home/kats/zspace/mozilla-git/widget/android/nsAppShell.cpp:72: warning:   when initialized here
/home/kats/zspace/mozilla-git/widget/android/nsAppShell.cpp: In member function 'void nsAppShell::PostEvent(mozilla::AndroidGeckoEvent*)':
/home/kats/zspace/mozilla-git/widget/android/nsAppShell.cpp:684: warning: comparison between signed and unsigned integer expressions
/home/kats/zspace/mozilla-git/widget/android/AndroidBridge.cpp: In member function 'void mozilla::AndroidBridge::GetSystemColors(mozilla::AndroidSystemColors*)':
/home/kats/zspace/mozilla-git/widget/android/AndroidBridge.cpp:1020: warning: comparison between signed and unsigned integer expressions
/home/kats/zspace/mozilla-git/widget/android/AndroidBridge.cpp:1030: warning: suggest parentheses around arithmetic in operand of '|'
/home/kats/zspace/mozilla-git/widget/android/AndroidBridge.cpp: In member function 'void mozilla::AndroidBridge::GetIconForExtension(const nsACString_internal&, PRUint32, PRUint8*)':
/home/kats/zspace/mozilla-git/widget/android/AndroidBridge.cpp:1067: warning: comparison between signed and unsigned integer expressions
/home/kats/zspace/mozilla-git/widget/android/AndroidBridge.cpp:1068: warning: comparison between signed and unsigned integer expressions
/home/kats/zspace/mozilla-git/widget/android/AndroidBridge.cpp: In member function 'bool mozilla::AndroidBridge::ValidateBitmap(_jobject*, int, int)':
/home/kats/zspace/mozilla-git/widget/android/AndroidBridge.cpp:1521: warning: comparison between signed and unsigned integer expressions
/home/kats/zspace/mozilla-git/widget/android/AndroidBridge.cpp:1521: warning: comparison between signed and unsigned integer expressions
/home/kats/zspace/mozilla-git/widget/android/AndroidBridge.cpp: In member function 'bool mozilla::AndroidBridge::LockWindow(void*, unsigned char**, int*, int*, int*, int*)':
/home/kats/zspace/mozilla-git/widget/android/AndroidBridge.cpp:1979: warning: 'typedef' was ignored in this declaration
Comment 1 Kartikaya Gupta (email:kats@mozilla.com) 2012-07-11 12:52:09 PDT
Created attachment 641169 [details] [diff] [review]
Patch

since i'm waiting for a build anyway...
Comment 2 Kartikaya Gupta (email:kats@mozilla.com) 2012-07-11 13:27:39 PDT
Pushed to try at https://tbpl.mozilla.org/?tree=Try&rev=df3bee014ce9 to make sure nothing breaks
Comment 3 Chris Peterson [:cpeterson] 2012-07-12 09:13:29 PDT
Comment on attachment 641169 [details] [diff] [review]
Patch

LGTM. These warnings have been bugging me, too. :)
Comment 4 Kartikaya Gupta (email:kats@mozilla.com) 2012-07-12 09:54:24 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/641a641e3903
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-07-12 17:52:29 PDT
https://hg.mozilla.org/mozilla-central/rev/641a641e3903

Note You need to log in before you can comment on or make changes to this bug.