Door hangers are not keyboard accessible

VERIFIED FIXED in Firefox 15

Status

()

Firefox for Android
General
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: eeejay, Assigned: eeejay)

Tracking

unspecified
Firefox 16
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox15 verified)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

6 years ago
When a doorhanger is shown, arrowing around moves the focus on the items below the doorhanger.
(Assignee)

Comment 2

6 years ago
Created attachment 641256 [details] [diff] [review]
Make door hangers keybaord navigable.
Attachment #641256 - Flags: review?(margaret.leibovic)

Comment 3

6 years ago
Comment on attachment 641256 [details] [diff] [review]
Make door hangers keybaord navigable.

I don't see this patch causing any problems, but does it also let you navigate to the checkbox and buttons in the doorhanger? I'm not sure how keyboard navigation works, but I'd want to make sure users can interact with those other items.
Attachment #641256 - Flags: review?(margaret.leibovic) → review+
Comment on attachment 641256 [details] [diff] [review]
Make door hangers keybaord navigable.

Margaret, this patch only makes such items that aren't focusable by default focusable, too. The checkbox and buttons are focusable by default. This just makes sure the text view is as well, and thus reachable via a directional controller or bluetooth keyboard.
(Assignee)

Comment 5

6 years ago
Yes, you could navigate to the controls. I made the TextView focusable too so the user could navigate to it as well and have it read.
OS: Linux → Android
Hardware: x86_64 → ARM

Comment 6

6 years ago
Thanks for clarifying! I'm glad to hear the buttons and checkbox are focusable by default.
(Assignee)

Comment 7

6 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/54cfa52ffb78
Assignee: nobody → eitan
Target Milestone: --- → Firefox 15
Target Milestone: Firefox 15 → Firefox 16

Comment 8

6 years ago
https://hg.mozilla.org/mozilla-central/rev/54cfa52ffb78
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Comment on attachment 641256 [details] [diff] [review]
Make door hangers keybaord navigable.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Neglegance to make the text view that contains the doorhanger question focusable.
User impact if declined: TalkBack users using a keyboard only will not be able to read the question asked by a doorhanger. Affects all Gingerbread users.
Testing completed (on m-c, etc.): Yes, on a local build.
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None.
Attachment #641256 - Flags: approval-mozilla-aurora?
Comment on attachment 641256 [details] [diff] [review]
Make door hangers keybaord navigable.

[Triage Comment]
Approved for FF15 given that the a11y reward outweighs the near-zero risk to a non-a11y user.
Attachment #641256 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 12

6 years ago
Verified on Xperia mini pro on password door hanger.
Status: RESOLVED → VERIFIED

Updated

6 years ago
status-firefox15: fixed → verified

Updated

6 years ago
Depends on: 774209
You need to log in before you can comment on or make changes to this bug.