Rename MOZ_ANGLE to MOZ_ANGLE_RENDERER [Port |Bug 772457 Remove compile-time option to disable ANGLE, replace it by an option to disable WebGL altogether (also disabling ANGLE)|]

RESOLVED FIXED in Thunderbird 19.0

Status

MailNews Core
Build Config
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Philip Chee, Assigned: InvisibleSmiley)

Tracking

(Blocks: 1 bug)

Trunk
Thunderbird 19.0
Dependency tree / graph
Bug Flags:
in-testsuite -

Thunderbird Tracking Flags

(thunderbird16-)

Details

(URL)

Attachments

(2 attachments)

Comment hidden (empty)
(Reporter)

Comment 1

5 years ago
https://hg.mozilla.org/mozilla-central/rev/3391c610940b#l1.12
https://hg.mozilla.org/mozilla-central/rev/3391c610940b#l2.12
Summary: Rename MOZ_ANGLE is renamed to MOZ_ANGLE_RENDERER [Port |Bug 772457 Remove compile-time option to disable ANGLE, replace it by an option to disable WebGL altogether (also disabling ANGLE)|] → Rename MOZ_ANGLE to MOZ_ANGLE_RENDERER [Port |Bug 772457 Remove compile-time option to disable ANGLE, replace it by an option to disable WebGL altogether (also disabling ANGLE)|]
(Reporter)

Comment 2

5 years ago
Do we need to change these comm-central files as well?
config/autoconf.mk.in
configure.in
(In reply to Philip Chee from comment #2)
> Do we need to change these comm-central files as well?
> config/autoconf.mk.in
> configure.in

Yes.
Assignee: installer → nobody
Component: Installer → Build Config
Depends on: 772457
Flags: in-testsuite-
Product: SeaMonkey → MailNews Core
Duplicate of this bug: 773538
tracking-thunderbird16: --- → ?
Please explain why you think we should track a bug when requesting tracking.

In this case, I can't see anything that needs to be tracked here - the defaults will still work for the standard Thunderbird configuration. For users using non-standard configs, they might need to specify two options rather than one, but that's not something worth tracking. If someone ports this, then I'd accept a patch to have it synchronised, but I'm not going to direct effort onto it specifically.
tracking-thunderbird16: ? → -
(Reporter)

Updated

5 years ago
Blocks: 803168
(Assignee)

Comment 6

5 years ago
Created attachment 678134 [details] [diff] [review]
part 1: rename [Checkin: Comment 8]

I'm attaching two patches, one with the simple renaming (which will need no real review or discussion) and another one on top of the first that ports the extra bits from bug 772457 and some follow-up bugs concerning the same configure.in section. If it's decided that the latter one should have its own set of bugs or not be done at all, at least the first part won't be lost work.

Please note that I'm not a build system expert or anything close to that; I just felt this should be done rather sooner than later.
Assignee: nobody → jh
Status: NEW → ASSIGNED
Attachment #678134 - Flags: review?(bugspam.Callek)
(Assignee)

Comment 7

5 years ago
Created attachment 678135 [details] [diff] [review]
part 2: rest [Checkin: Comment 9]

[Feel free to add or change reviewers as necessary.]
Attachment #678135 - Flags: review?(bugspam.Callek)

Updated

5 years ago
Attachment #678134 - Flags: review?(bugspam.Callek) → review+

Updated

5 years ago
Attachment #678135 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Comment 8

5 years ago
Comment on attachment 678134 [details] [diff] [review]
part 1: rename [Checkin: Comment 8]

http://hg.mozilla.org/comm-central/rev/84173f8837f7
Attachment #678134 - Attachment description: part 1: rename → part 1: rename [Checkin: Comment 8]
(Assignee)

Comment 9

5 years ago
Comment on attachment 678135 [details] [diff] [review]
part 2: rest [Checkin: Comment 9]

http://hg.mozilla.org/comm-central/rev/afdbfb6acd3c
(with anti-bitrot for the first configure.in hunk)
Attachment #678135 - Attachment description: part 2: rest → part 2: rest [Checkin: Comment 9]
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 19.0
You need to log in before you can comment on or make changes to this bug.