Last Comment Bug 773153 - With options('allow_xml'), the statement "" < ""; is rejected.
: With options('allow_xml'), the statement "" < ""; is rejected.
Status: RESOLVED FIXED
: regression, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- normal (vote)
: mozilla16
Assigned To: general
:
:
Mentors:
Depends on:
Blocks: jsfunfuzz 769072
  Show dependency treegraph
 
Reported: 2012-07-11 23:04 PDT by Jesse Ruderman
Modified: 2012-07-12 09:36 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (1.44 KB, patch)
2012-07-11 23:29 PDT, :Benjamin Peterson
n.nethercote: review+
Details | Diff | Splinter Review

Description Jesse Ruderman 2012-07-11 23:04:12 PDT
js> void options('allow_xml')

js> ('' < '')
false
js> '' < ''
typein:2: SyntaxError: missing ; before statement:
typein:2: '' < ''
typein:2: ...^

jsfunfuzz noticed this because the decompiler turns something that compiles into something that doesn't:

js> (function() { ('' < '') })
(function () {"" < "";})
js> (function () {"" < "";})
typein:5: SyntaxError: missing ; before statement:
typein:5: (function () {"" < "";})
typein:5: .................^

The first bad revision is:
changeset:   418ad69cfe52
user:        Benjamin Peterson
date:        Mon Jul 09 23:43:06 2012 -0700
summary:     Bug 769072: retroactively apply strict mode to defaults. r=njn
Comment 1 :Benjamin Peterson 2012-07-11 23:29:17 PDT
Created attachment 641370 [details] [diff] [review]
fix

Curse you, xml...
Comment 2 Nicholas Nethercote [:njn] 2012-07-12 00:00:06 PDT
Comment on attachment 641370 [details] [diff] [review]
fix

Review of attachment 641370 [details] [diff] [review]:
-----------------------------------------------------------------

e4x cannot die quickly enough.
Comment 3 Gary Kwong [:gkw] [:nth10sd] 2012-07-12 00:04:20 PDT
Thanks for the quick fix & review!

http://hg.mozilla.org/integration/mozilla-inbound/rev/341214c1b964
Comment 4 Ed Morley [:emorley] 2012-07-12 09:36:03 PDT
https://hg.mozilla.org/mozilla-central/rev/341214c1b964

Note You need to log in before you can comment on or make changes to this bug.