Adblock Plus button relocates if a separator is placed to the right of it.

RESOLVED INVALID

Status

()

Firefox
Toolbars and Customization
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: xircal, Unassigned)

Tracking

(Blocks: 1 bug)

13 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

Updated Ablock Plus to 2.1.1


Actual results:

If a separator has been placed to the right of the ABP button and the add-on is updated to the latest version i.e. 2.1.1, the button will relocate to the end of the location bar the next time Firefox is restarted. 

Removing the separator ensures the ABP button remains wherever the user placed it. 

According to the developer, the problem is due to a bug in Firefox. See this thread on the ABP forum: https://adblockplus.org/forum/viewtopic.php?p=61513#p61513

Screenshots:
ABP button with separators on both sides: http://imageshack.us/photo/my-images/338/abpleft.png/
After restarting FF, the button has relocated to the right of the location bar: http://imageshack.us/photo/my-images/39/abprelocated.png/


Expected results:

The ABP button should remain in place regardless of whether separators are used to customize the toolbar layout.
(Reporter)

Updated

6 years ago
Component: Untriaged → Toolbars
Summary: Adblock Plus button relocates if a separator is place to the right of it. → Adblock Plus button relocates if a separator is placed to the right of it.

Comment 1

6 years ago
I think it's a dupe of bug 575500 that's rising since update 2.1 of ABP.
Blocks: 467520

Comment 2

6 years ago
That's different from bug 575500 and actually an Adblock Plus issue - the separator has a different ID each time so Adblock Plus cannot restore its position.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.