[TABLET] VKB is not dismissed when switching tabs

RESOLVED WORKSFORME

Status

()

Firefox for Android
Keyboards and IME
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: Paul Feher, Unassigned)

Tracking

16 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox21 affected, firefox22 unaffected, firefox23 unaffected, fennec+)

Details

(Whiteboard: [tablet])

(Reporter)

Description

6 years ago
Nightly Fennec 16.0a1 (2012-07-11)
Aurora Fennec 15.0a2 (2012-07-11)
Device: Samsung Galaxy Tab
OS: Android 3.1

Steps to Reproduce:
1. Open two or more pages in different tabs.
2. Open a new tab and load a page that contains a text input field and tap on it for the VKB to appear (ex: google.com)
3. Select another tab.

Expected:
The VKB is dismissed.

Actual:
The VKB is not dismissed.
(Reporter)

Updated

6 years ago
Whiteboard: [tablet]
(Reporter)

Comment 1

6 years ago
The issue is still reproducible for:
Firefox Mobile Native 15.0b4 build1 (2012-08-08)
Device: Samsung Galaxy Tab (Android 3.1)
tracking-fennec: --- → ?
Switching tabs _should_ cause a focus change. The focus change should cause the keyboard to dismiss. Can we retest and check on phones too?
tracking-fennec: ? → +
Keywords: qawanted
(Reporter)

Comment 3

5 years ago
I can reproduce the issue on phones too (HTC Desire Z 2.3.3 Nightly 18.0a1 2012-09-05), using the STR from comment0 but only using the pages in witch the text field is auto-focused (google.com classic version). On tablets the issue is still reproducible. Also the issue appears only if the tab menu is opened during the load of the page that contains the text input field, if not, opening the tab menu dismisses the VKB.
status-firefox16: --- → affected
status-firefox17: --- → affected
status-firefox18: --- → affected
Keywords: qawanted
This is still an issue on Firefox Mobile 21 beta 2 on the Samsung Galaxy Tab (Android 4.0.4)
status-firefox16: affected → ---
status-firefox17: affected → ---
status-firefox18: affected → ---
status-firefox21: --- → affected
status-firefox22: --- → affected
status-firefox23: --- → affected

Comment 5

5 years ago
This is somehow not reproducing on Fx 22 Beta 3. 
Also due to changes of the Tab Drawer - auto hide - this is not reproducing neither on Fx 23 Aurora.
status-firefox22: affected → unaffected
status-firefox23: affected → unaffected

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.