If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

D3 library (SVG) is buggy on Firefox (it works on other browsers)

RESOLVED DUPLICATE of bug 769115

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 769115
5 years ago
5 years ago

People

(Reporter: usaformegibito, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_3) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.47 Safari/536.11

Steps to reproduce:

simply copied and pasted this code and observed the rendering with all browsers.


Actual results:

please refer to http://stackoverflow.com/questions/11444558/d3-arrows-in-force-directed-graph#comment15107168_11444558


Expected results:

it should have rendered like this http://bl.ocks.org/1153292

Comment 1

5 years ago
Works For Me
I can reproduce the misaligned arrows with Firefox13.0.1 and Seamonkey trunk on Windows7/32
Status: UNCONFIRMED → NEW
Component: Untriaged → SVG
Ever confirmed: true
Product: Firefox → Core
Version: 13 Branch → Trunk
I can repro against 13, 14 and 15, but it's WFM against Nightly (16).

Progression/Fixed Range:
Last good nightly: 2012-07-08 (i.e. Bug)
First bad nightly: 2012-07-09 (i.e. WFM)

Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=fa1bf35aae2e&tochange=8129536fb25c
I see the misaligned arrows with:
Mozilla/5.0 (Windows NT 6.1; rv:16.0) Gecko/16.0 Firefox/16.0 SeaMonkey/2.13a1
Build identifier: 20120712003002

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769115
You need to log in before you can comment on or make changes to this bug.