Last Comment Bug 773347 - GCLI hidden commands don't execute properly
: GCLI hidden commands don't execute properly
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: Trunk
: All All
: P1 normal (vote)
: Firefox 17
Assigned To: Joe Walker [:jwalker] (needinfo me or ping on irc)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 10:38 PDT by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2012-08-25 17:01 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (14.66 KB, patch)
2012-07-17 04:33 PDT, Joe Walker [:jwalker] (needinfo me or ping on irc)
fayearthur: review+
Details | Diff | Splinter Review
v2 (14.35 KB, patch)
2012-08-02 11:59 PDT, Joe Walker [:jwalker] (needinfo me or ping on irc)
no flags Details | Diff | Splinter Review
v3 (10.26 KB, patch)
2012-08-20 06:34 PDT, Joe Walker [:jwalker] (needinfo me or ping on irc)
no flags Details | Diff | Splinter Review

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-07-12 10:38:31 PDT

    
Comment 1 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-07-16 04:36:45 PDT
This bug is about fixing the mechanism for hiding bugs. Setting 'hidden:true' on a command or parameter was possible ages ago, but not included in unit tests, so the feature rotted.

The situation was that setting 'hidden:true' correctly removed a command from the completion, but also prevented it's execution because it didn't appear in any 'predictions' and so was marked ERROR.

This brings it back and adds tests.
Comment 2 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-07-17 04:33:01 PDT
Created attachment 642913 [details] [diff] [review]
v1


The changes that you see in https://github.com/harthur/gcli/pull/3 are in this patch in:
- browser/devtools/commandline/gcli.jsm
- browser/devtools/commandline/test/browser_gcli_web.js

(GCLI contains a node script that builds these files from the GCLI sources)

Also this patch includes:
- Make the hidden state of 'cmd refresh' depend on whether the user has set
  the preference to point to a command directory.
- Now that hidden commands can be executed, I've removed the commenting out
  of the tests, so the commands are tested again.
Comment 3 Heather Arthur [:harth] 2012-07-17 13:02:32 PDT
Comment on attachment 642913 [details] [diff] [review]
v1

Review of attachment 642913 [details] [diff] [review]:
-----------------------------------------------------------------

looks good, except for a maybe redundant test.

::: browser/devtools/commandline/test/browser_gcli_web.js
@@ +3071,5 @@
> +  });
> +
> +  helpers.setInput('tshidden');
> +  helpers.check({
> +    input:  'tshidden',

commented on the pull request, but it looks like the exact same test is here twice.
Comment 4 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-08-02 11:59:40 PDT
Created attachment 648421 [details] [diff] [review]
v2

Removed duplicate test
Comment 5 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-08-20 06:34:56 PDT
Created attachment 653349 [details] [diff] [review]
v3

rebase
Comment 6 Rob Campbell [:rc] (:robcee) 2012-08-24 06:29:37 PDT
Backed out in:

https://hg.mozilla.org/integration/fx-team/rev/f4596ef17eed
Comment 7 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-08-24 11:16:12 PDT
Re-land
https://tbpl.mozilla.org/?tree=Fx-Team&rev=c80d0e010be3
Comment 8 Dave Camp (:dcamp) 2012-08-25 16:58:47 PDT
https://hg.mozilla.org/mozilla-central/rev/6b00d1edb2e7
Comment 9 Dave Camp (:dcamp) 2012-08-25 17:01:15 PDT
Oops, https://hg.mozilla.org/mozilla-central/rev/efd1509146d5 was the relanded changeset.

Note You need to log in before you can comment on or make changes to this bug.