Last Comment Bug 773419 - [adbe 3298954] Flash crashes in F_313572943______
: [adbe 3298954] Flash crashes in F_313572943______
Status: VERIFIED FIXED
: crash
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: unspecified
: x86 Windows NT
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 13:35 PDT by Benjamin Smedberg [:bsmedberg]
Modified: 2012-08-29 09:17 PDT (History)
5 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
dxdiag output (31.72 KB, text/plain)
2012-07-30 07:55 PDT, Martijn Wargers [:mwargers] (not working for Mozilla)
no flags Details
dxdiag output (31.82 KB, text/plain)
2012-07-30 10:06 PDT, Martijn Wargers [:mwargers] (not working for Mozilla)
no flags Details

Description Benjamin Smedberg [:bsmedberg] 2012-07-12 13:35:51 PDT
report bp-c83f2586-89cb-4f4e-8101-4fbb82120712 .

More reports at https://crash-stats.mozilla.com/report/list?signature=F_313572943______

This is a signature which shows up for Flash 11.1 and 11.2 and is now the #5 topcrash for crashes in FlashPlayerPlugin processes.

0 	NPSWF32_11_3_300_265.dll 	F_313572943______ 	F1210552929_________________________________________:43
1 	NPSWF32_11_3_300_265.dll 	F1942853272_____________ 	
2 	NPSWF32_11_3_300_265.dll 	F670213680__________________ 	F1795780087______________________________________________________:1125
3 	NPSWF32_11_3_300_265.dll 	F110704195______________________ 	
4 	NPSWF32_11_3_300_265.dll 	F1183674311___________________________________ 	F1556456750_______________________________________:322
5 	NPSWF32_11_3_300_265.dll 	F1954011561_____________________________ 	F1556456750_______________________________________:3014
6 	NPSWF32_11_3_300_265.dll 	F1341112214_____________________________________ 	F1556456750_______________________________________:3461
7 	NPSWF32_11_3_300_265.dll 	F_115065918___________________ 	F1157779535_________________________________________________________________________:2814
8 	NPSWF32_11_3_300_265.dll 	F1546913566_____________________________________ 	F1157779535_________________________________________________________________________:3894
9 	NPSWF32_11_3_300_265.dll 	F1187989989____________________________________________ 	F1157779535_________________________________________________________________________:346
10 	user32.dll 	InternalCallWinProc 	
11 	user32.dll 	GetRealWindowOwner 	
12 	user32.dll 	DispatchClientMessage 	
13 	user32.dll 	__fnDWORD 	
14 	ntdll.dll 	KiUserCallbackDispatcher 	
15 	ntdll.dll 	KiUserApcDispatcher 	
16 	user32.dll 	RealDefWindowProcW 	
17 	user32.dll 	DefWindowProcW 	
18 	NPSWF32_11_3_300_265.dll 	F1546913566_____________________________________ 	F1157779535_________________________________________________________________________:4748
19 	NPSWF32_11_3_300_265.dll 	F1187989989____________________________________________ 	F1157779535_________________________________________________________________________:346
20 	user32.dll 	InternalCallWinProc
Comment 1 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-07-26 09:19:48 PDT
I get this crash with version 268 of Flash, when viewing any video on http://zie.nl (for instance http://www.zie.nl/video/algemeen/Assad-staat-op-punt-van-vertrekken/m1mzu9afcdk6 ) and going to full screen. It doesn't happen often, but 1 in 20 times or so.
Just doing it quickly after each other makes it quite easily reproducible for me.
https://crash-stats.mozilla.com/report/index/bp-ffe0790a-5fd2-46ad-ab3f-28a532120726
Comment 2 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-07-26 15:05:50 PDT
For me, this is really easy to reproduce. Let me know if you need any help with this (stack traces, etc).
Comment 3 Jeromie Clark 2012-07-26 17:13:18 PDT
dxdiag output would be helpful.
Comment 4 Jeromie Clark 2012-07-26 17:24:59 PDT
This is Adobe internal bug 3297109
Comment 5 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-07-30 07:55:46 PDT
Created attachment 647174 [details]
dxdiag output

(In reply to Jeromie Clark from comment #3)
> dxdiag output would be helpful.

I assume this is what you need?
Comment 6 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-07-30 07:59:18 PDT
I also seem to get this crash every time when trying to go full screen on the NOS site where you can watch the Olympic games online: http://nos.nl/os2012/play/13/
https://crash-stats.mozilla.com/report/index/bp-8d6d846b-ceec-49fc-8ebe-f417e2120730
Comment 7 Jeromie Clark 2012-07-30 08:58:51 PDT
Thanks, this is exactly what we need.  

It looks like there are more current drivers available for your video card (yours are from 2009).  

I think this is the right link, but they also have an auto-detection tool: 
http://support.amd.com/us/gpudownload/windows/legacy/Pages/legacy-radeonaiw-vista32.aspx

Please let us know if this resolves the issue.  If so, we can blacklist the old driver version to mitigate the crash.  Users with old drivers will just fall back to software video.
Comment 8 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-07-30 10:06:39 PDT
Created attachment 647205 [details]
dxdiag output

After installing the whole thing and restarting my machine, I'm still getting these crashes:
https://crash-stats.mozilla.com/report/index/bp-966447a2-3121-47e2-8acc-f9fdf2120730
Comment 9 Jeromie Clark 2012-07-30 10:35:45 PDT
Okay.  One last thing to check.  :)

Does disabling Hardware Acceleration in Flash Player resolve the crashes?

Right Click on a SWF and choose Settings.  
(If it's greyed out, choose a different SWF.  I like: http://www.homestarrunner.com/intro.html)

Click the left-most tab, and uncheck Use Hardware Acceleration. 

Restart Firefox
Comment 10 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-07-30 11:03:02 PDT
Yea, disabling Hardware Acceleration seems to fix the crashes on this machine.
Comment 11 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-08-06 12:49:58 PDT
Jeromie, what is the solution to this bug? Will there be an update for Flash soon that will fix this issue?
Comment 12 Jeromie Clark 2012-08-06 13:28:00 PDT
It's currently assigned to someone to fix.
Comment 13 smadayag 2012-08-27 13:49:54 PDT
fix rolled out with FP 11.4, Dolores.  11.4.402.265 was release on 8/21.  closing.
Comment 14 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-08-29 09:17:09 PDT
Yeah, seems fixed with Flash 11.4.

Note You need to log in before you can comment on or make changes to this bug.