Last Comment Bug 773450 - Lines don't show up in some Google Maps directions
: Lines don't show up in some Google Maps directions
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: mozilla17
Assigned To: Jonathan Watt [:jwatt] (back in October - email directly if necessary)
: Simona B [:simonab ]
Mentors:
http://goo.gl/maps/hSI0
: 779432 (view as bug list)
Depends on: 789122
Blocks: 769742
  Show dependency treegraph
 
Reported: 2012-07-12 14:39 PDT by :Margaret Leibovic
Modified: 2014-01-10 10:40 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified
verified


Attachments
patch (2.81 KB, patch)
2012-07-17 12:16 PDT, Jonathan Watt [:jwatt] (back in October - email directly if necessary)
roc: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description :Margaret Leibovic 2012-07-12 14:39:07 PDT
This happens for some sets of directions, and seems to only happen with transit direction (not walking or driving). Here's a testcase: http://goo.gl/maps/YLPH.

Tested on latest nightly (7/12). I can't reproduce on Aurora.
Comment 1 Logan Rosen [:Logan] 2012-07-14 21:15:25 PDT
I've been experiencing this on Mac OS X in the latest nightly builds for a bunch of directions on Google Maps - including driving, walking, etc. Sometimes, it is ameliorated by zooming in. I'm going to try to figure out a regression range, although it's going to be difficult to do an STR, since the lines seem to sporadically work.
Comment 2 Logan Rosen [:Logan] 2012-07-14 21:34:48 PDT
Last good nightly: 2012-07-09
First bad nightly: 2012-07-10

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b6fb3d9bd1b9&tochange=02b26fb307b4

Was able to reproduce consistently with the default zoom level at this link: http://goo.gl/maps/hSI0
Comment 3 Logan Rosen [:Logan] 2012-07-15 10:37:01 PDT
This is occurring for me in the latest nightly build on Windows as well, so I am marking the OS as All.
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-15 22:38:24 PDT
The first bad revision is:
changeset:   98666:6e0f0a9228ce
user:        Jonathan Watt <jwatt@jwatt.org>
date:        Mon Jul 09 02:04:56 2012 +0100
summary:     Bug 769742 - Account for nsSVGOuterSVGFrames' border/padding offset by giving nsSVGOuterSVGFrame an anonymous child to wrap its real children. r=roc.
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-15 22:39:24 PDT
Thanks for the nightly regression range Logan - made finding a narrower regression range much easier!
Comment 6 Vladimir Vukicevic [:vlad] [:vladv] 2012-07-17 08:44:04 PDT
I'm seeing this as well, though only on Win32 -- couldn't reproduce it on OSX.
Comment 7 Logan Rosen [:Logan] 2012-07-17 11:34:36 PDT
Definitely still able to reproduce on OS X with http://goo.gl/maps/hSI0 in the latest nightly build.
Comment 8 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-07-17 12:16:53 PDT
Created attachment 643081 [details] [diff] [review]
patch

The problem occurs when nsDisplayOuterSVG::Paint() passes the nsSVGOuterSVGFrame to nsSVGUtils::PaintFrameWithEffects. PaintFrameWithEffects checks the dirty area against the visual overflow rect of the element, but to do that it takes the transform returned by nsSVGUtils::GetCanvasTM with the children-only component of that transform canceled out. To get that it calls HasChildrenOnlyTransform, which after bug 769742 returns false for nsSVGOuterSVGFrame. Unfortunately bug 769742 didn't also change nsSVGUtils::GetCanvasTM to stop returning the nsSVGSVGElement's transforms for nsSVGOuterSVGFrame.
Comment 9 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-07-17 13:00:03 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/f805b2c3b3b4
Comment 10 Ed Morley [:emorley] 2012-07-18 05:54:37 PDT
https://hg.mozilla.org/mozilla-central/rev/f805b2c3b3b4
Comment 11 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-07-18 08:17:04 PDT
Comment on attachment 643081 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 769742
User impact if declined: Directions on Goggle Maps are broken
Testing completed (on m-c, etc.): Passed mozilla-inbound and not on mozilla-central
Risk to taking this patch (and alternatives if risky): very low
String or UUID changes made by this patch: none
Comment 12 Alex Keybl [:akeybl] 2012-07-18 17:37:35 PDT
Comment on attachment 643081 [details] [diff] [review]
patch

[Triage Comment]
Google Maps regression in FF16. Approved for Aurora 16.
Comment 13 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-07-30 07:39:29 PDT
Pushed https://hg.mozilla.org/releases/mozilla-aurora/rev/b13cc8063a77
Comment 14 Jason Duell [:jduell] (needinfo me) 2012-08-01 22:12:39 PDT
*** Bug 779432 has been marked as a duplicate of this bug. ***
Comment 15 Simona B [:simonab ] 2012-09-19 06:06:49 PDT
Verified using Firefox 16 beta 3 on Windows 7, Ubuntu 12.04 and Mac OS X 10.7 - that all the lines are properly displayed on Google maps directories (verified on the provided maps from this bug, bug 779432 and some random ones).

Mozilla/5.0 (Windows NT 6.1; rv:16.0) Gecko/20100101 Firefox/16.0
Mozilla/5.0 (X11; Linux i686; rv:16.0) Gecko/20100101 Firefox/16.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:16.0) Gecko/20100101 Firefox/16.0
Comment 16 Simona B [:simonab ] 2012-10-15 07:10:17 PDT
Verified on Firefox 17 beta 1 that all the lines are properly displayed on Google maps directory. 

Verified on Windows 7, Ubuntu 12.04 and Mac OS X 10.7:
Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/17.0 Firefox/17.0
Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/17.0 Firefox/17.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/17.0 Firefox/17.0
Comment 17 Tracy Walker [:tracy] 2014-01-10 10:40:13 PST
mass remove verifyme requests greater than 4 months old

Note You need to log in before you can comment on or make changes to this bug.