PDF's fail to download correctly - failure is when spaces are in file name

RESOLVED DUPLICATE of bug 221028

Status

()

Core
General
RESOLVED DUPLICATE of bug 221028
5 years ago
3 years ago

People

(Reporter: Phil Wyatt, Unassigned)

Tracking

(Blocks: 1 bug)

13 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 641749 [details]
Firefox glitch.pdf

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

We have an internal intranet application that produces PDF files. When these are downloaded in Firefox we get a spurious result when the file names have spaces in them. They do not get the .pdf extension and therefore they are not recognised as pdf's


Actual results:

When these are downloaded Internet Explorer and Safari both download them correctly and show the names complete with spaces and the .pdf extension however Firefox fails at the first "space" and then as there is no extension they are not recognised as pdf's and the user has to select the required program to open the file.


Expected results:

The full name of the pdf and the extension should show in the download
(Reporter)

Comment 1

5 years ago
We are in the process of removing the spaces in our internal application however this does seem like a bug that could affect many people.
What exact headers are you sending?  Per spec, filenames with spaces in them are supposed to be placed in double quotes.  Are you doing that?
(Reporter)

Comment 3

5 years ago
I will check with the developers - has this changed recently because it works in earlier versions of firefox (V9)?
Hmm. Julian?

Comment 5

5 years ago
Test case: http://greenbytes.de/tech/tc2231/#attwithasciifilenamenqws

As far as I know, it has always been like this. I would recommend not to change anything here to be more permissive; next people will ask for "," or ";" not to be treated as delimiters. People really need to fix their code to use the correct syntax.

Updated

5 years ago
OS: Windows 7 → All
Hardware: x86_64 → All

Updated

5 years ago
Blocks: 609667
(Reporter)

Comment 6

5 years ago
My apologies - just checked on older version and its the same. I will get our developers to make the required changes.

Keep up the good work

Updated

5 years ago
Duplicate of this bug: 786784

Comment 8

4 years ago
I believe this bug can be closed.
closed, because it was not an firefox bug

feel free to reopen if you feel this is not correct and you have additonal information for us.

thanks for the help to make firefox better.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID

Updated

3 years ago
Resolution: INVALID → DUPLICATE
Duplicate of bug: 221028
You need to log in before you can comment on or make changes to this bug.