Last Comment Bug 773586 - Initialize JM PICGenInfo::pc field
: Initialize JM PICGenInfo::pc field
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: Jan de Mooij [:jandem]
: general
Mentors:
Depends on:
Blocks: 771130
  Show dependency treegraph
 
Reported: 2012-07-13 03:47 PDT by Jan de Mooij [:jandem]
Modified: 2012-07-13 20:23 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (18.29 KB, patch)
2012-07-13 03:47 PDT, Jan de Mooij [:jandem]
bhackett1024: review+
Details | Diff | Review

Description Jan de Mooij [:jandem] 2012-07-13 03:47:31 PDT
Created attachment 641804 [details] [diff] [review]
Patch

For bug 771130, I need JM PICs to have a valid pc. Turns out there's already a field, it just has to be initialized.

The patch also removes BaseIC::op and changes its users to call f.pc(). Any idea why this field was added?

Since CALLELEM no longer has to push |this|, the stack store for that is also removed.
Comment 2 Ryan VanderMeulen [:RyanVM] 2012-07-13 20:23:51 PDT
https://hg.mozilla.org/mozilla-central/rev/a75570f52a03

Note You need to log in before you can comment on or make changes to this bug.