###!!! ABORT: attempt to initialize OOP crash reporter before in-process crashreporter!: 'gExceptionHandler != NULL'

RESOLVED FIXED

Status

()

Toolkit
Breakpad Integration
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: cjones, Assigned: cjones)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox15+ fixed, firefox16+ fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment, 1 obsolete attachment)

When launching subprocess with crashreporter disabled (but --enable-crashreporter).

Forgot CrashReporter::GetEnabled().
Created attachment 642102 [details] [diff] [review]
Check GetEnabled() before OOPInit()

This is hosing all local b2g devs.
Assignee: nobody → jones.chris.g
Attachment #642102 - Flags: review?(ted.mielczarek)
Attachment #642102 - Flags: review?(benjamin)
Created attachment 642103 [details] [diff] [review]
Check GetEnabled() before OOPInit(), v1.1

Missed a spot.
Attachment #642102 - Attachment is obsolete: true
Attachment #642102 - Flags: review?(ted.mielczarek)
Attachment #642102 - Flags: review?(benjamin)
Attachment #642103 - Flags: review?(ted.mielczarek)
Attachment #642103 - Flags: review?(benjamin)
Blocks: 771251
Attachment #642103 - Flags: review?(ted.mielczarek) → review+
Attachment #642103 - Flags: review?(benjamin)
https://hg.mozilla.org/mozilla-central/rev/08c5d1085a44
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 642103 [details] [diff] [review]
Check GetEnabled() before OOPInit(), v1.1

Sorry about that! thanks for the quick turnaround.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 771251
User impact if declined: B2G noworkee (assuming we take bug 771251)
Testing completed (on m-c, etc.): verified via engineers being unstuck
Basically no-risk.
Attachment #642103 - Flags: approval-mozilla-aurora?

Comment 5

5 years ago
Comment on attachment 642103 [details] [diff] [review]
Check GetEnabled() before OOPInit(), v1.1

[Triage Comment]
Approving for Beta 15 along with the other bugs blocking bug 771251.
Attachment #642103 - Flags: approval-mozilla-aurora? → approval-mozilla-beta+

Updated

5 years ago
status-firefox15: --- → affected
status-firefox16: --- → fixed
tracking-firefox15: --- → +
tracking-firefox16: --- → +
https://hg.mozilla.org/releases/mozilla-beta/rev/30c2a881b7d6

Firefox 15 wasn't really affected... ;-)
status-firefox15: affected → fixed

Comment 7

5 years ago
Are there any reliable STR QA can verify this bug with?
No. This is a B2G bug and prevented apps from starting at all.

Updated

5 years ago
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.