Last Comment Bug 773842 - Fix build warnings under content/
: Fix build warnings under content/
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla17
Assigned To: David Zbarsky (:dzbarsky)
:
Mentors:
: 755037 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 15:57 PDT by David Zbarsky (:dzbarsky)
Modified: 2013-01-19 05:57 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (9.65 KB, patch)
2012-07-13 15:58 PDT, David Zbarsky (:dzbarsky)
no flags Details | Diff | Review
Patch (16.54 KB, patch)
2012-07-18 12:43 PDT, David Zbarsky (:dzbarsky)
mounir: review+
Details | Diff | Review

Description David Zbarsky (:dzbarsky) 2012-07-13 15:57:05 PDT

    
Comment 1 David Zbarsky (:dzbarsky) 2012-07-13 15:58:23 PDT
Created attachment 642120 [details] [diff] [review]
Patch
Comment 2 Mounir Lamouri (:mounir) 2012-07-14 02:34:11 PDT
David, do you think you could try to add FAIL_ON_WARNINGS = 1 at some places in content/ subdirectories?
Comment 3 David Zbarsky (:dzbarsky) 2012-07-18 12:43:52 PDT
Created attachment 643524 [details] [diff] [review]
Patch
Comment 4 Mounir Lamouri (:mounir) 2012-08-06 08:19:18 PDT
Comment on attachment 643524 [details] [diff] [review]
Patch

Review of attachment 643524 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with the nit below fixed.

BTW, make sure to send this to try with "-p all", "-p macosx" isn't going to be enough.

::: content/base/src/nsContentIterator.cpp
@@ +1199,5 @@
>    PRInt32 endOffset = mRange->EndOffset();
>    MOZ_ASSERT(mCommonParent && startParent && endParent);
>    // Bug 767169
> +  MOZ_ASSERT((PRUint32)startOffset <= startParent->Length() &&
> +             (PRUint32)endOffset <= endParent->Length());

PRUint32(foo) is more C++'y.
Comment 5 David Zbarsky (:dzbarsky) 2012-08-10 11:01:48 PDT
Pushed with your comment.
https://hg.mozilla.org/integration/mozilla-inbound/rev/a0dc2d401d71
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-08-11 19:55:50 PDT
https://hg.mozilla.org/mozilla-central/rev/a0dc2d401d71
Comment 7 :Ms2ger 2013-01-19 05:57:24 PST
*** Bug 755037 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.