Firefox should allow configuration of fourth and fifth mouse button behaviour

RESOLVED DUPLICATE of bug 1052947

Status

()

Core
Event Handling
RESOLVED DUPLICATE of bug 1052947
6 years ago
2 years ago

People

(Reporter: annihilannic, Unassigned)

Tracking

13 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:13.0) Gecko/20120606 Firefox/13.0
Build ID: 20120606130836

Steps to reproduce:

Attempted to use fourth and fifth mouse buttons for a third party application (e.g. push to talk for Teamspeak/Raidcall/etc)


Actual results:

When Firefox is focussed, it moves back or forward in the browsing history.


Expected results:

We should have the option to disable this behaviour.
(Reporter)

Comment 1

6 years ago
Ref example discussed here: 

  http://forums.mozillazine.org/viewtopic.php?f=38&t=2397383

There are many other such discussions.  A number of people have mentioned reconfiguring the fourth and fifth mouse button behaviour in the mouse software, however this is NOT the solution, as that means effectively disabling the generic fourth/fifth mouse button behaviour in other applications, which should not be necessary.

I don't think a UI change is necessary, but the facility to configure these buttons through about:config would be ideal.

Comment 2

5 years ago
This is an option that definitely needs to be added.
I was very surprised to find that it hasn't already been added.

Comment 3

5 years ago
This problem does not strictly occur with just windows platforms. I am a linux user with only the generic X.org mouse drivers installed.

Comment 4

5 years ago
this is very anoying...

Comment 5

5 years ago
sometimes I'm filling up a big form, or checking thousands of checkboxes, or scrolling down to the infinite (in facebook for exemple),
and BUUMMM,
I hit the Mouse 4/5 button.... everything goes to space...
(It's completly ridiculous...)
Component: Untriaged → Event Handling
Product: Firefox → Core

Comment 6

2 years ago
Some of this stuff has been discussed very recently in bug 1052947
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1052947
You need to log in before you can comment on or make changes to this bug.