Last Comment Bug 773933 - Remove libs rules from browser/components/sessionstore/src/Makefile.in
: Remove libs rules from browser/components/sessionstore/src/Makefile.in
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Session Restore (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 17
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
:
Mentors:
: 775338 (view as bug list)
Depends on:
Blocks: nomakerules
  Show dependency treegraph
 
Reported: 2012-07-14 02:11 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2012-08-07 03:32 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (4.32 KB, patch)
2012-07-14 02:12 PDT, :Ms2ger (⌚ UTC+1/+2)
ted: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2012-07-14 02:11:34 PDT

    
Comment 1 :Ms2ger (⌚ UTC+1/+2) 2012-07-14 02:12:05 PDT
Created attachment 642195 [details] [diff] [review]
Patch v1
Comment 2 Ted Mielczarek [:ted.mielczarek] 2012-07-23 12:36:39 PDT
Comment on attachment 642195 [details] [diff] [review]
Patch v1

Review of attachment 642195 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/sessionstore/src/Makefile.in
@@ +31,1 @@
>  	SessionStore.jsm \

Fix the indent while you're here?

::: config/rules.mk
@@ +1392,5 @@
>  ################################################################################
> +# Copy each element of EXTRA_JS_MODULES to JS_MODULES_PATH, or
> +# $(FINAL_TARGET)/modules if that isn't defined.
> +ifndef JS_MODULES_PATH
> +JS_MODULES_PATH := $(FINAL_TARGET)/modules

You could just write this as
JS_MODULES_PATH ?= $(FINAL_TARGET)/modules
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2012-08-04 01:54:36 PDT
https://hg.mozilla.org/mozilla-central/rev/c6ae36a7f8a9
Comment 4 Ed Morley [:emorley] 2012-08-04 11:29:34 PDT
Backed out with the mass tree revert to get rid of the OS X M5 orange:
https://hg.mozilla.org/mozilla-central/rev/c801b99d726f
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-08-04 13:36:08 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/d6318b897437
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-08-04 18:41:28 PDT
https://hg.mozilla.org/mozilla-central/rev/d6318b897437
Comment 7 Mike Hommey [:glandium] 2012-08-07 03:32:26 PDT
*** Bug 775338 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.