If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

java.lang.ClassCastException: org.mozilla.gecko.AwesomeBarTab$AwesomeEntryViewHolder cannot be cast to org.mozilla.gecko.AllPagesTab$SearchEntryViewHolder at org.mozilla.gecko.AllPagesTab$AwesomeBarCursorAdapter.getView(AllPagesTab.java)

RESOLVED FIXED in Firefox 20

Status

()

Firefox for Android
Awesomescreen
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Scoobidiver (away), Assigned: bnicholson)

Tracking

({crash})

16 Branch
Firefox 21
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(firefox18 wontfix, firefox19 wontfix, firefox20 fixed, firefox21 fixed)

Details

(Whiteboard: [native-crash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
There are two crashes, one in 16.0a1/20120706 and one in 16.0a1/20120713, bp-45b36386-2cf8-489e-a309-803782120714.

java.lang.ClassCastException: org.mozilla.gecko.AwesomeBarTab$AwesomeEntryViewHolder cannot be cast to org.mozilla.gecko.AllPagesTab$SearchEntryViewHolder
	at org.mozilla.gecko.AllPagesTab$AwesomeBarCursorAdapter.getView(AllPagesTab.java:325)
	at android.widget.AbsListView.obtainView(AbsListView.java:2039)
	at android.widget.ListView.makeAndAddView(ListView.java:1772)
	at android.widget.ListView.fillSpecific(ListView.java:1318)
	at android.widget.ListView.layoutChildren(ListView.java:1603)
	at android.widget.AbsListView.onLayout(AbsListView.java:1890)
	at android.view.View.layout(View.java:11278)
	at android.view.ViewGroup.layout(ViewGroup.java:4224)
	at android.widget.FrameLayout.onLayout(FrameLayout.java:431)
	at android.view.View.layout(View.java:11278)
	at android.view.ViewGroup.layout(ViewGroup.java:4224)
	at android.widget.LinearLayout.setChildFrame(LinearLayout.java:1628)
	at android.widget.LinearLayout.layoutVertical(LinearLayout.java:1486)
	at android.widget.LinearLayout.onLayout(LinearLayout.java:1399)
	at android.view.View.layout(View.java:11278)
	at android.view.ViewGroup.layout(ViewGroup.java:4224)
	at android.widget.FrameLayout.onLayout(FrameLayout.java:431)
	at android.view.View.layout(View.java:11278)
	at android.view.ViewGroup.layout(ViewGroup.java:4224)
	at android.widget.LinearLayout.setChildFrame(LinearLayout.java:1628)
	at android.widget.LinearLayout.layoutVertical(LinearLayout.java:1486)
	at android.widget.LinearLayout.onLayout(LinearLayout.java:1399)
	at android.view.View.layout(View.java:11278)
	at android.view.ViewGroup.layout(ViewGroup.java:4224)
	at android.widget.FrameLayout.onLayout(FrameLayout.java:431)
	at android.view.View.layout(View.java:11278)
	at android.view.ViewGroup.layout(ViewGroup.java:4224)
	at android.widget.LinearLayout.setChildFrame(LinearLayout.java:1628)
	at android.widget.LinearLayout.layoutVertical(LinearLayout.java:1486)
	at android.widget.LinearLayout.onLayout(LinearLayout.java:1399)
	at android.view.View.layout(View.java:11278)
	at android.view.ViewGroup.layout(ViewGroup.java:4224)
	at android.widget.FrameLayout.onLayout(FrameLayout.java:431)
	at android.view.View.layout(View.java:11278)
	at android.view.ViewGroup.layout(ViewGroup.java:4224)
	at android.view.ViewRootImpl.performTraversals(ViewRootImpl.java:1489)
	at android.view.ViewRootImpl.handleMessage(ViewRootImpl.java:2442)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4575)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:789)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:556)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.ClassCastException%3A+org.mozilla.gecko.AwesomeBarTab%24AwesomeEntryViewHolder+cannot+be+cast+to+org.mozilla.gecko.AllPagesTab%24SearchEntryViewHolder+at+org.mozilla.gecko.AllPagesTab%24AwesomeBarCursorAdapter.getView%28AllPagesTab.java%29
(Reporter)

Updated

5 years ago
status-firefox16: --- → affected
status-firefox17: --- → affected
Version: Trunk → Firefox 16
(Reporter)

Updated

5 years ago
status-firefox18: --- → affected
(Assignee)

Comment 1

5 years ago
Created attachment 702065 [details] [diff] [review]
Check view tag's type before casting to viewholder

This shouldn't be necessary, but we're doing something wrong somewhere, and this is a band-aid until we know what the cause is.
Assignee: nobody → bnicholson
Status: NEW → ASSIGNED
Attachment #702065 - Flags: review?(mark.finkle)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 829567
Attachment #702065 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/821258fa9f9c
(Assignee)

Comment 4

5 years ago
Comment on attachment 702065 [details] [diff] [review]
Check view tag's type before casting to viewholder

[Approval Request Comment]
Bug caused by (feature/regressing bug #): unknown
User impact if declined: occasional crash on awesomescreen
Testing completed (on m-c, etc.): just landed m-i
Risk to taking this patch (and alternatives if risky): very low risk - just adds instanceof check
String or UUID changes made by this patch: none
Attachment #702065 - Flags: approval-mozilla-beta?
Attachment #702065 - Flags: approval-mozilla-aurora?

Comment 5

5 years ago
Comment on attachment 702065 [details] [diff] [review]
Check view tag's type before casting to viewholder

Not a critical fix for beta, given this is a longstanding issue. Approving for Aurora.
Attachment #702065 - Flags: approval-mozilla-beta?
Attachment #702065 - Flags: approval-mozilla-beta-
Attachment #702065 - Flags: approval-mozilla-aurora?
Attachment #702065 - Flags: approval-mozilla-aurora+

Comment 6

5 years ago
https://hg.mozilla.org/mozilla-central/rev/821258fa9f9c
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
https://hg.mozilla.org/releases/mozilla-aurora/rev/c26befa04d80
status-firefox16: affected → ---
status-firefox17: affected → ---
status-firefox18: affected → wontfix
status-firefox19: --- → wontfix
status-firefox20: --- → fixed
status-firefox21: --- → fixed
You need to log in before you can comment on or make changes to this bug.