Last Comment Bug 774062 - Build failure using inbound 6ceeca8b4b73 "command 'expand "" -F:d3dx9_43.dll "../../dist/bin"' failed, return code -1"
: Build failure using inbound 6ceeca8b4b73 "command 'expand "" -F:d3dx9_43.dll ...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Windows 7
: -- critical (vote)
: mozilla17
Assigned To: Ed Morley [:emorley]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-15 04:39 PDT by Ed Morley [:emorley]
Modified: 2012-08-23 03:51 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Build log (1001.07 KB, text/plain)
2012-07-15 04:39 PDT, Ed Morley [:emorley]
no flags Details
Patch v1 (1.42 KB, patch)
2012-08-14 15:24 PDT, Ed Morley [:emorley]
ted: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2012-07-15 04:39:20 PDT
Created attachment 642366 [details]
Build log

Windows SDK version: 7.0A
Using VC 2010 built-in SDK
Built from: https://hg.mozilla.org/integration/mozilla-inbound/rev/6ceeca8b4b73

.mozconfig:
mk_add_options MOZ_OBJDIR=d:/obj-inbound
mk_add_options MOZ_MAKE_FLAGS=-j12

Command used:
python build/pymake/make.py -s -f client.mk

{
...
...
glslang_tab.cpp

c:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\INCLUDE\typeinfo(157) : warning C4275: non dll-interface class 'stdext::exception' used as base for dll-interface class 'std::bad_cast'

        c:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\INCLUDE\exception(218) : see declaration of 'stdext::exception'

        c:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\INCLUDE\typeinfo(156) : see declaration of 'std::bad_cast'

c:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\INCLUDE\typeinfo(178) : warning C4275: non dll-interface class 'stdext::exception' used as base for dll-interface class 'std::bad_typeid'

        c:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\INCLUDE\exception(218) : see declaration of 'stdext::exception'

        c:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\INCLUDE\typeinfo(177) : see declaration of 'std::bad_typeid'

d:\obj-inbound\gfx\angle\Makefile:117:0: command 'expand "" -F:d3dx9_43.dll "../../dist/bin"' failed, return code -1
d:\srcdirs\inbound\config\makefiles\target_libs.mk:103:0: command 'c:/mozilla-build/python/python.exe d:/srcdirs/inbound/build/pymake/pymake/../make.py -C angle libs' failed, return code 2
d:\srcdirs\inbound\config\makefiles\target_libs.mk:18:0: command 'c:/mozilla-build/python/python.exe d:/srcdirs/inbound/build/pymake/pymake/../make.py -C gfx libs' failed, return code 2
d:\srcdirs\inbound\config\rules.mk:611:0: command 'c:/mozilla-build/python/python.exe d:/srcdirs/inbound/build/pymake/pymake/../make.py libs_tier_platform' failed, return code 2
d:\srcdirs\inbound\config\rules.mk:576:0: command 'c:/mozilla-build/python/python.exe d:/srcdirs/inbound/build/pymake/pymake/../make.py  tier_platform' failed, return code 2
d:\srcdirs\inbound\client.mk:349:0: command 'c:/mozilla-build/python/python.exe d:/srcdirs/inbound/build/pymake/pymake/../make.py -j12 -C d:/obj-inbound' failed, return code 2
d:\srcdirs\inbound\client.mk:149:0: command 'c:/mozilla-build/python/python.exe d:/srcdirs/inbound/build/pymake/pymake/../make.py -f d:/srcdirs/inbound/client.mk realbuild' failed, return code 2
}

Full log attached.

I did spot this during configure:
{
Found DirectX SDK via registry, using C:\Program Files (x86)\Microsoft DirectX SDK (June 2010)
find: C:\Program Files (x86)\Microsoft DirectX SDK (June 2010)/Redist: No such file or directory
find: C:\Program Files (x86)\Microsoft DirectX SDK (June 2010)/Redist: No such file or directory
}

Does that mean I didn't choose the correct options during the DirectX SDK install? I did deselect some of the example/docs stuff amongst other things. 

Either way, I guess we should bail in configure if the redist folder is required...
Comment 1 Ed Morley [:emorley] 2012-07-24 06:26:40 PDT
I'm still unable to build because of this btw :-(
Comment 2 Ed Morley [:emorley] 2012-08-14 15:24:01 PDT
Created attachment 651909 [details] [diff] [review]
Patch v1

Re-installing the DirectX SDK with the "DirectX Redistributable Files" option selected, fixed the problem.

This patch makes sure we error out in configure if the redistributable files cannot be found, rather than letting us get halfway through the build before breaking with an unclear error message.
Comment 4 Ed Morley [:emorley] 2012-08-23 03:51:14 PDT
https://hg.mozilla.org/mozilla-central/rev/8ce5250fe80f

Note You need to log in before you can comment on or make changes to this bug.