Last Comment Bug 774454 - Fix PA detection hack in sydneyaudio ALSA
: Fix PA detection hack in sydneyaudio ALSA
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla17
Assigned To: Matthew Gregan [:kinetik]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 14:08 PDT by Matthew Gregan [:kinetik]
Modified: 2012-07-20 06:45 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v0 (1.18 KB, patch)
2012-07-16 14:10 PDT, Matthew Gregan [:kinetik]
no flags Details | Diff | Review
patch v0 (1.18 KB, patch)
2012-07-16 14:12 PDT, Matthew Gregan [:kinetik]
cajbir.bugzilla: review+
Details | Diff | Review

Description Matthew Gregan [:kinetik] 2012-07-16 14:08:51 PDT
The current code almost always evaluates to true due to misuse of strncmp().
Comment 1 Matthew Gregan [:kinetik] 2012-07-16 14:10:25 PDT
Created attachment 642722 [details] [diff] [review]
patch v0
Comment 2 Matthew Gregan [:kinetik] 2012-07-16 14:12:14 PDT
Created attachment 642724 [details] [diff] [review]
patch v0

Previously attached version had a typo.
Comment 3 Matthew Gregan [:kinetik] 2012-07-19 12:08:58 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/752d38520b85
Comment 4 Ed Morley [:emorley] 2012-07-20 06:45:38 PDT
https://hg.mozilla.org/mozilla-central/rev/752d38520b85

Note You need to log in before you can comment on or make changes to this bug.