Don't request search suggestions for strings that look like URLs

RESOLVED DUPLICATE of bug 820473

Status

()

Firefox for Android
Awesomescreen
RESOLVED DUPLICATE of bug 820473
6 years ago
5 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

({privacy})

15 Branch
All
Android
privacy
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Created attachment 642781 [details] [diff] [review]
patch

As discussed in bug 769145 comment 21, some of the privacy concerns about search suggestions in the address bar (bug 586885) could be mitigated if we do not request search suggestions when the user types a string that is likely to be a URL.

This patch uses the same heuristic we use for switching between "search" and "url" keyboard modes:  If the string contains a period (.) or a colon (:), and the first period or colon occurs before any space characters, then we treat it as a URL and will not request search suggestions.

So if you start typing "maps.google.com" then we will display suggestions up until you type the first dot.  This does not totally eliminate the privacy concern, since the first component of the hostname ("maps" in this case) is still submitted to the search provider.  This portion is quite frequently enough to identify the site you are visiting, but compared to a full URL it is less likely to contain more personally-identifying information.  I think this is the best we can do without reducing the usefulness of the search suggestion feature.
Attachment #642781 - Flags: review?(bnicholson)
(Assignee)

Comment 1

6 years ago
Comment on attachment 642781 [details] [diff] [review]
patch

Waiting until the UX and/or privacy teams weigh in on whether we want to make this change.  Madhava, any opinion?
Attachment #642781 - Flags: review?(bnicholson) → feedback?(madhava)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 765201
Checking for a slash in addition to checking for a dot would avoid leaking the path of dotless-hostname intranet URLs, too. (But, yeah, : and . already go a long way. Thanks for creating a patch!)
This patch might have the downside of removing support for domain auto-completion that can happen when google suggest gives you "maps.google.com" after you type "maps.google."
(Assignee)

Comment 5

5 years ago
(In reply to Mark Finkle (:mfinkle) from comment #4)
> This patch might have the downside of removing support for domain
> auto-completion that can happen when google suggest gives you
> "maps.google.com" after you type "maps.google."

Those suggestions are actually really annoying, since clicking on them takes you to a Google search for "maps.google.com" instead of going directly to the site.  Is there a good way we can provide separate search suggestions and URL suggestions, like Chrome and stock Browser?  Until we can, I'd rather *not* show suggestions like these.
FWIW, you can long tap on the suggestion to copy it to the URL bar.
(In reply to Brian Nicholson (:bnicholson) from comment #6)
> FWIW, you can long tap on the suggestion to copy it to the URL bar.

Sweetness. We need to advertise this kind of stuff in more ways.
(Assignee)

Updated

5 years ago
Attachment #642781 - Flags: feedback?(madhava)
There's more recent activity in bug 820473 for the same bug, so duping this one.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 820473
You need to log in before you can comment on or make changes to this bug.