Closed Bug 774534 Opened 10 years ago Closed 10 years ago

Disable per-tab JS memory reporting in Firefox 16

Categories

(Core :: XPConnect, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: n.nethercote, Assigned: n.nethercote)

References

Details

Bug 687724 added per-tab reporting of JS memory consumption.  It landed near the end of the Firefox 16 dev cycle, and two distinct crashes are showing up when loading about:memory (bug 772615 and 773533), neither of which was fixed before the uplift.

We should disable it in FF16 and let it bake for the full FF17 release cycle.
Actually, bug 773533 was caused by DOM orphan reporting (bug 704623).

If the fix in bug 772615 works, back-porting it to Aurora may be easier/better than disabling per-tab JS reporting.  Let's wait and see.
> If the fix in bug 772615 works, back-porting it to Aurora may be
> easier/better than disabling per-tab JS reporting.  Let's wait and see.

The fix has been backported and seems to be working, so there's nothing to do here.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.