Last Comment Bug 774598 - Enable VP8 asm on OpenBSD/amd64 & OpenBSD/i386
: Enable VP8 asm on OpenBSD/amd64 & OpenBSD/i386
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: Other OpenBSD
: -- normal (vote)
: mozilla17
Assigned To: Landry Breuil (:gaston)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 01:45 PDT by Landry Breuil (:gaston)
Modified: 2012-07-18 05:57 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
enable libvpx asm on openbsd (3.89 KB, patch)
2012-07-17 01:47 PDT, Landry Breuil (:gaston)
tterribe: review+
Details | Diff | Review

Description Landry Breuil (:gaston) 2012-07-17 01:45:45 PDT
Similar to #572876 and prompted by #750447 comment 10.

I've testbuild m-c on amd64 and i386, ran the regress tests on amd64 (the 4 failures are unrelated and probably because the remote host i'm using doesnt have audio) :

$TEST_PATH=content/media/test/ gmake -C obj mochitest-plain
..
5669 INFO Passed: 5182
5670 INFO Failed: 4
5671 INFO Todo:   19
5672 INFO SimpleTest FINISHED
5673 INFO TEST-INFO | Ran 0 Loops
5674 INFO SimpleTest FINISHED
INFO | automation.py | Application ran for: 0:23:03.342845
INFO | automation.py | Reading PID log: /tmp/tmp9D8jCCpidlog
WARNING | automationutils.processLeakLog() | refcount logging is off, so leaks can't be detected!

INFO | runtests.py | Running tests: end.
mochitest-plain failed:
6 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_a4_tone.html | The audioAvailable event's time attribute was invalid.
7 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_a4_tone.html | Check amount of signal data processed - got 103424, expected 
8 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_a4_tone.html | Check signal present - got false, expected true
9 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_a4_tone.html | Check mute fragments present - got false, expected true

I've watched content/media/test/skip.webm in nightly with asm enabled without a noticeable difference but i'm on a very slow computer.
Comment 1 Landry Breuil (:gaston) 2012-07-17 01:47:37 PDT
Created attachment 642891 [details] [diff] [review]
enable libvpx asm on openbsd
Comment 3 Ed Morley [:emorley] 2012-07-18 05:57:52 PDT
https://hg.mozilla.org/mozilla-central/rev/b02ca10caa59

Note You need to log in before you can comment on or make changes to this bug.