Last Comment Bug 774667 - Make media.navigator.enabled visible
: Make media.navigator.enabled visible
Status: VERIFIED FIXED
[qa!]
:
Product: Core
Classification: Components
Component: WebRTC (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: mozilla17
Assigned To: Anant Narayanan [:anant]
: Jason Smith [:jsmith]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 08:09 PDT by Anant Narayanan [:anant]
Modified: 2012-07-31 17:42 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add media.navigator.enabled to default prefs (9.50 KB, patch)
2012-07-17 08:24 PDT, Anant Narayanan [:anant]
no flags Details | Diff | Review
Add media.navigator.enabled to default prefs (9.95 KB, patch)
2012-07-17 10:02 PDT, Anant Narayanan [:anant]
no flags Details | Diff | Review
Make media.navigator.enabled visible in about:config (870 bytes, patch)
2012-07-26 09:40 PDT, Anant Narayanan [:anant]
gavin.sharp: review+
Details | Diff | Review

Description Anant Narayanan [:anant] 2012-07-17 08:09:58 PDT
The pref is not visible via about:config and has to be created manually at the moment.
Comment 1 Anant Narayanan [:anant] 2012-07-17 08:24:45 PDT
Created attachment 642965 [details] [diff] [review]
Add media.navigator.enabled to default prefs

Trim some whitespace and add media.navigator.enabled to default pref list (turned off).
Comment 2 Jason Smith [:jsmith] 2012-07-17 08:30:23 PDT
(In reply to Anant Narayanan [:anant] from comment #0)
> The pref is not visible via about:config and has to be created manually at
> the moment.

Can we have a bug for making this visible in the desktop webrt?
Comment 3 Jason Smith [:jsmith] 2012-07-17 09:24:42 PDT
(In reply to Jason Smith [:jsmith] from comment #2)
> (In reply to Anant Narayanan [:anant] from comment #0)
> > The pref is not visible via about:config and has to be created manually at
> > the moment.
> 
> Can we have a bug for making this visible in the desktop webrt?

Or we could just implement it here along with the desktop firefox changes.
Comment 4 Anant Narayanan [:anant] 2012-07-17 10:02:37 PDT
Created attachment 643014 [details] [diff] [review]
Add media.navigator.enabled to default prefs

Add pref to WebRT as well.
Comment 5 :Felipe Gomes (needinfo me!) 2012-07-17 14:48:17 PDT
Is there a reason not to use all.js instead and include it everywhere?

I too dislike trailing spaces but we usually don't fix them in unrelated changes because your changeset will look obscure and it will change the blame making it harder to find the original bug where those lines were added.
Comment 6 Randell Jesup [:jesup] 2012-07-23 05:34:07 PDT
anant: can you address Felipe's comments and repost?  Also, if there any other peers who can review this patch, let's add them as possible reviewers since people using nightlies are getting tripped up looking for the pref, and felipe's away, and may not get to this bug this week even when he gets back.
Comment 7 Anant Narayanan [:anant] 2012-07-26 09:40:33 PDT
Created attachment 646177 [details] [diff] [review]
Make media.navigator.enabled visible in about:config

Sounds good! Felipe is probably busy this week, but I'm not sure who else to flag.
Comment 8 Anant Narayanan [:anant] 2012-07-26 09:58:42 PDT
Thanks Gavin!

https://hg.mozilla.org/integration/mozilla-inbound/rev/80a25e052d86
Comment 9 :Ehsan Akhgari (busy, don't ask for review please) 2012-07-27 09:02:01 PDT
https://hg.mozilla.org/mozilla-central/rev/80a25e052d86
Comment 10 Jason Smith [:jsmith] 2012-07-30 08:17:08 PDT
On a fresh firefox profile, I am seeing media.navigator.enabled set to false in the prefs, so the firefox piece works here. However, the web runtime piece does not work - checking prefs.js shows no evidence of the media.navigator.enabled pref at all.

Any ideas?
Comment 11 :Felipe Gomes (needinfo me!) 2012-07-31 17:41:09 PDT
(In reply to Jason Smith [:jsmith] from comment #10)
> On a fresh firefox profile, I am seeing media.navigator.enabled set to false
> in the prefs, so the firefox piece works here. However, the web runtime
> piece does not work - checking prefs.js shows no evidence of the
> media.navigator.enabled pref at all.
> 
> Any ideas?

prefs.js in the webapprt/defaults/preferences folder are overrides/additions to the prefs defined by all.js. The runtime first loads all.js and then prefs.js. So the pref is not supposed to show up in that file, but if you load about:config inside the webapprt you'll see that media.navigator.enabled is present. (I just did this and verified that the pref is there)
Comment 12 Jason Smith [:jsmith] 2012-07-31 17:42:08 PDT
Alright, I'll mark as verified then given that you were able to see in about:config for the runtime.

Note You need to log in before you can comment on or make changes to this bug.