Last Comment Bug 774677 - Auto hide toolbars in full-screen is broken on OSX LION
: Auto hide toolbars in full-screen is broken on OSX LION
Status: RESOLVED DUPLICATE of bug 740148
:
Product: Firefox
Classification: Client Software
Component: Untriaged (show other bugs)
: 14 Branch
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 08:33 PDT by Francois Guerraz
Modified: 2012-10-13 10:49 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Francois Guerraz 2012-07-17 08:33:46 PDT
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

Switch to full screen mode


Actual results:

FF becomes full screen but the tool-bars and tabs bar stayed even if browser.fullscreen.autohide is true


Expected results:

Bars should hide automatically, only the web page should appear in full screen.
Comment 1 Stefan Arentz [:st3fan] 2012-07-17 09:36:12 PDT
(In reply to Francois Guerraz from comment #0)
> Bars should hide automatically, only the web page should appear in full
> screen.

On Lion, Firefox has the same behaviour as Safari: it shows toolbar/location bar and tabs. It is by design.
Comment 2 Jared Wein [:jaws] (please needinfo? me) 2012-07-17 09:38:30 PDT
I think Lion fullscreen and Firefox fullscreen behave differently. Can you try pressing F11 while in Lion fullscreen?
Comment 3 Francois Guerraz 2012-07-17 09:43:59 PDT
(In reply to Stefan Arentz [:st3fan] from comment #1)
> On Lion, Firefox has the same behaviour as Safari: it shows toolbar/location
> bar and tabs. It is by design.

Hi,

1) Doing the same thing as the native browser on the target platform is not necessarily a good idea: if I liked Safari, I'd use it, I wouldn't bother with FF.
2) On Safari you can right-click on the address bar in FS mode and hide it, it will reappear when leaving FS, you can't on FF
3) If it's a design choice either get rid of the option which is now useless or, more clever, set it to false by default and let the users who want the old behaviour live happily ever after.
Comment 4 Francois Guerraz 2012-07-17 09:46:22 PDT
(In reply to Jared Wein [:jaws] from comment #2)
> I think Lion fullscreen and Firefox fullscreen behave differently. Can you
> try pressing F11 while in Lion fullscreen?

Yes, it doesn't change anything.
Comment 5 José Jeria 2012-07-17 09:55:13 PDT
Note: Safari still shows the tab bar after you selected to hide the toolbar.
Comment 6 Francois Guerraz 2012-07-17 10:02:29 PDT
(In reply to José Jeria from comment #5)
> Note: Safari still shows the tab bar after you selected to hide the toolbar.
That makes it 50% better than FF!

By the way, I've just shown this "feature" to my colleague (who's a Chrome user), his reaction was "That's not Full Screen, is it?" and he also used other words that decency unfortunately doesn't allow me to use here.
Comment 7 Stefan Arentz [:st3fan] 2012-07-17 10:06:33 PDT
(In reply to Francois Guerraz from comment #6)
> (In reply to José Jeria from comment #5)
> > Note: Safari still shows the tab bar after you selected to hide the toolbar.
> That makes it 50% better than FF!
> 
> By the way, I've just shown this "feature" to my colleague (who's a Chrome
> user), his reaction was "That's not Full Screen, is it?" and he also used
> other words that decency unfortunately doesn't allow me to use here.

So maybe the bug should instead be:

"Please re-introduce Presentation mode as an alternative to Lion Full Screen Mode".

 S.
Comment 8 Francois Guerraz 2012-07-17 10:20:08 PDT
(In reply to Stefan Arentz [:st3fan] from comment #7)
> So maybe the bug should instead be:
> 
> "Please re-introduce Presentation mode as an alternative to Lion Full Screen
> Mode".
> 
>  S.
That would be enough to please me (and maybe other users) but having two different "full screen modes" (even if they are called differently) might look a bit messy while we could just have :
* the Lion Full Screen Mode
* with browser.fullscreen.autohide=false by default if you want be consistent with what people are running away from (aka Safari)
* and maybe by making this option more accessible in the in the UI (a new option in the right click menu on the toolbars in FS mode?).

But again, yes, re-introducing Presentation mode would do the trick.

François.
Comment 9 Francois Guerraz 2012-07-17 11:15:45 PDT
I realise that my reaction is a bit "Who Moved My Cheese?".
Let me just add that I find Lion Full Screen Mode great from an OS integration point of view (the transition definitely looks better, etc.). I just regret that it doesn't really "look" Full Screen any more and I really thought it was a bug at first (because of the configuration option still being present). I just wish I could have the best of the two worlds :)
Comment 10 José Jeria 2012-07-18 11:04:49 PDT
Duplicate of bug 740148 that requests browser.fullscreen.autohide to work again. Please reopen if you disagree.

*** This bug has been marked as a duplicate of bug 740148 ***
Comment 11 acetrip 2012-10-13 10:49:17 PDT
I have the same problem on FF 16 with mountain lion,
it really means there is no real full screen when you have the tabs and bar etc. up there.. please fix

Note You need to log in before you can comment on or make changes to this bug.