WebGL compositing broken with basic layers

RESOLVED FIXED in Firefox 15

Status

()

Core
Graphics: Layers
P1
critical
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: bjacob, Assigned: jgilbert)

Tracking

({regression})

unspecified
mozilla17
regression
Points:
---

Firefox Tracking Flags

(firefox14- wontfix, firefox15+ verified, firefox16+ verified, firefox17+ verified, firefox-esr10- unaffected)

Details

Attachments

(2 attachments)

STR:
* set layers.acceleration.disabled=true
* visit any page with a WebGL animation

actual results:
animation is frozen, you can get a new frame by switching tabs.

Last good nightly: march 26, http://hg.mozilla.org/mozilla-central/rev/ba4983d9c1f9
first bad nightly: march 27, http://hg.mozilla.org/mozilla-central/rev/c3cb87871829
(Assignee)

Comment 1

5 years ago
This is very likely to be a regression from bug 735378.
Severity: normal → critical
Depends on: 735378
Keywords: regression
OS: Windows 7 → All
Priority: -- → P1
Hardware: x86_64 → All
(Reporter)

Comment 2

5 years ago
This bug is a strong argument in favor of running tests with BasicLayers. Don't need any specific hardware for that, just run with this preference: layers.acceleration.disabled=true. It's still what the majority of our Windows users use, and the performance can still be acceptable for simple games.
(Assignee)

Comment 3

5 years ago
Created attachment 643107 [details] [diff] [review]
Mark our reused buffer as dirty

Adds the needed Flush and MarkDirty.
Attachment #643107 - Flags: review?(bas.schouten)
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

5 years ago
Assignee: jgilbert → nobody
Component: Canvas: WebGL → Graphics: Layers
Attachment #643107 - Flags: review?(bas.schouten) → review+
Assignee: nobody → jgilbert
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/cedfa313d168
(Assignee)

Updated

5 years ago
Target Milestone: --- → mozilla17
https://hg.mozilla.org/mozilla-central/rev/cedfa313d168
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
status-firefox-esr10: --- → ?
status-firefox14: --- → affected
status-firefox15: --- → affected
status-firefox16: --- → affected
status-firefox17: --- → fixed
tracking-firefox-esr10: --- → ?
tracking-firefox14: --- → ?
tracking-firefox15: --- → ?
tracking-firefox16: --- → ?
tracking-firefox17: --- → ?
(Assignee)

Comment 6

5 years ago
Comment on attachment 643107 [details] [diff] [review]
Mark our reused buffer as dirty

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 735378
User impact if declined: WebGL will display uselessly on BasicLayers. This is an uncommon combination, but it does occur. This is worse than simply failing to start WebGL.
Testing completed (on m-c, etc.): On m-c and easy to test.
Risk to taking this patch (and alternatives if risky): Very low. The problem is now well understood and the fix is simple.
String or UUID changes made by this patch: None.

Testing this is easy:
Set the pref 'layers.acceleration.disabled' to true, and create a new window. WebGL should fail to display properly, even if it works fine without the change to the pref.
Attachment #643107 - Attachment is patch: true
Attachment #643107 - Flags: approval-mozilla-beta?
Attachment #643107 - Flags: approval-mozilla-aurora?

Comment 7

5 years ago
If bug 735378 is the regressing issue, then the ESR is unaffected.
status-firefox-esr10: ? → unaffected
status-firefox14: affected → wontfix
tracking-firefox-esr10: ? → -
tracking-firefox14: ? → -
tracking-firefox15: ? → +
tracking-firefox16: ? → +
tracking-firefox17: ? → +

Comment 8

5 years ago
Comment on attachment 643107 [details] [diff] [review]
Mark our reused buffer as dirty

[Triage Comment]
Approving for both Aurora 16 and Beta 15, since this is a 14 regression and has a low-risk fix.
Attachment #643107 - Flags: approval-mozilla-beta?
Attachment #643107 - Flags: approval-mozilla-beta+
Attachment #643107 - Flags: approval-mozilla-aurora?
Attachment #643107 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 9

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/8dda64a9d0cc
status-firefox16: affected → fixed
(Assignee)

Comment 10

5 years ago
Created attachment 645598 [details] [diff] [review]
backport to beta 15

Beta backport.
Attachment #645598 - Flags: review+
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/f670d47f696c
status-firefox15: affected → fixed
Verified on Firefox 15 beta 3 that WebGL demos are not broken nor freeze when setting the user pref layers.acceleration.disabled to true.

Verified on Windows 7, Ubuntu 12.04 and Mac OS X 10.6:
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0
Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/20100101 Firefox/15.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:15.0) Gecko/20100101 Firefox/15.0
status-firefox15: fixed → verified
Keywords: verifyme
Verified on Firefox 16 beta 4 that WebGL demos are not broken nor freeze when user pref layers.acceleration.disabled=true.

Verified on several WebGL demos as:
http://sandbox.ayzenberg.com/creative_prototypes/html5_/webgl/prototypeEightMe.html
http://sandbox.ayzenberg.com/creative_prototypes/html5_/webgl/prototypeEightLOD.html
http://webglsamples.googlecode.com/hg/aquarium/aquarium.html

Verified on Windows 7, Ubuntu 12.04 and Mac OS X 10.7:
Mozilla/5.0 (Windows NT 6.1; rv:16.0) Gecko/20100101 Firefox/16.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:16.0) Gecko/20100101 Firefox/16.0
Mozilla/5.0 (X11; Linux i686; rv:16.0) Gecko/20100101 Firefox/16.0
status-firefox16: fixed → verified
QA Contact: simona.marcu
Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/17.0 Firefox/17.0
Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/17.0 Firefox/17.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/17.0 Firefox/17.0

Verified on Firefox 17 beta 1 that WebGL demos are not broken nor freeze (having the preference layers.acceleration.disabled set to true).

Verified on several WebGL demos as(on Win 7, Ubuntu 12.04 and Mac OS X 10.7):
http://sandbox.ayzenberg.com/creative_prototypes/html5_/webgl/prototypeEightMe.html
http://sandbox.ayzenberg.com/creative_prototypes/html5_/webgl/prototypeEightLOD.html
http://webglsamples.googlecode.com/hg/aquarium/aquarium.html
http://webglsamples.googlecode.com/hg/blob/blob.html
http://lights.elliegoulding.com/

On Ubuntu 12.04 with ATI Radeon 3000 GraphicsDriver Version3.3.11627 - Firefox crashes when loading any WebGL demo - filed Bug 801699 for this matter. The crash is not reproducible on a computer running Ubuntu with NVidia.
status-firefox17: fixed → verified
mass remove verifyme requests greater than 4 months old
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.