Last Comment Bug 774705 - Throw a TypeError when trying to construct an interface without a constructor
: Throw a TypeError when trying to construct an interface without a constructor
Status: RESOLVED FIXED
: dev-doc-needed
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: :Ms2ger
:
Mentors:
Depends on: 765464
Blocks: ParisBindings
  Show dependency treegraph
 
Reported: 2012-07-17 09:09 PDT by :Ms2ger
Modified: 2012-08-04 18:41 PDT (History)
3 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Part a: Update /resources (11.13 KB, patch)
2012-07-17 09:14 PDT, :Ms2ger
no flags Details | Diff | Review
Part b: Throw a TypeError (4.25 KB, patch)
2012-07-17 09:15 PDT, :Ms2ger
bzbarsky: review+
Details | Diff | Review

Description :Ms2ger 2012-07-17 09:09:46 PDT

    
Comment 1 :Ms2ger 2012-07-17 09:14:58 PDT
Created attachment 642991 [details] [diff] [review]
Part a: Update /resources

To pick up the fix to idlharness.js, because we totally throw a TypeError when calling new window[undefined]().
Comment 2 :Ms2ger 2012-07-17 09:15:29 PDT
Created attachment 642992 [details] [diff] [review]
Part b: Throw a TypeError
Comment 3 Boris Zbarsky [:bz] 2012-07-17 10:37:17 PDT
Comment on attachment 642992 [details] [diff] [review]
Part b: Throw a TypeError

r=me
Comment 4 :Aryeh Gregor (away until August 15) 2012-07-19 08:16:00 PDT
Comment on attachment 642991 [details] [diff] [review]
Part a: Update /resources

Not sure why you asked me for review.  I'm not a DOM owner or peer.  I think it would make sense if pulling updates to imported tests could be done with no review at all, but my review shouldn't help anything.
Comment 6 Ed Morley [:emorley] 2012-08-04 11:29:03 PDT
Backed out with the mass tree revert to get rid of the OS X M5 orange:
https://hg.mozilla.org/mozilla-central/rev/c801b99d726f

Note You need to log in before you can comment on or make changes to this bug.