Closed Bug 774725 Opened 7 years ago Closed 7 years ago

Navigation toolbar height increased by ~10px after bug 771826 landed

Categories

(Firefox :: Toolbars and Customization, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 18
Tracking Status
firefox17 + verified

People

(Reporter: jaws, Assigned: jaws)

References

Details

(Keywords: regression, Whiteboard: [Fx17])

Attachments

(2 files)

Attached image Screenshot of bug
STR:
1) In about:config, set:
1a)  social.enabled = true
1b)  social.manifest.motown = {"origin":"https://motown-dev.mozillalabs.com", "name":"MoTown", "workerURL":"https://motown-dev.mozillalabs.com/social/worker.js"}
2) Restart browser

See attached screenshot for comparison.
Whiteboard: [fx16]
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Whiteboard: [fx16] → [Fx17]
Attached patch PatchSplinter Review
I tried on Mac but didn't see the toolbar changing in height when the Social API was enabled/disabled.
Attachment #663619 - Flags: review?(felipc)
Attachment #663619 - Flags: review?(felipc) → review+
https://hg.mozilla.org/mozilla-central/rev/78c1ecf6bf13
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
Comment on attachment 663619 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 771826
User impact if declined: toolbar height will have grown more than we'd like
Testing completed (on m-c, etc.): on m-c and i tested it with an aurora build and confirmed that it worked as expected
Risk to taking this patch (and alternatives if risky): none expected
String or UUID changes made by this patch: none
Attachment #663619 - Flags: approval-mozilla-aurora?
Attachment #663619 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

The social.manifest.motown is not available in Firefox 17.0 (beta 6), but instead there is social.manifest.facebook. Changing it's value doesn't trigger the reported issue. Neither does manually adding a new preference entry for social.manifest.motown and setting the value mentioned in bug description.

Was the removal of social.manifest.motown preference intended?
Whiteboard: [Fx17] → [Fx17] [qa?]
The STR from comment 0 aren't relevant to current builds where there is already a social provider built-in (social.manifest.* has a default value).

The main idea here is to ensure that enabling social (e.g. Facebook) doesn't change the toolbar height. We fixed one instance of that in this bug, but have some other known issues: bug 811835 and bug 812488.
Marking this bug verified for Firefox 17, based on comment #6 and comment #7 (issue is not reproducible by enabling Facebook Social).
Whiteboard: [Fx17] [qa?] → [Fx17]
You need to log in before you can comment on or make changes to this bug.