Closed Bug 774842 Opened 8 years ago Closed 7 years ago

Implement new theme for the Find bar

Categories

(Firefox for Metro Graveyard :: Theme, defect)

x86_64
Windows 8.1
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bbondy, Assigned: bbondy)

References

Details

(Keywords: feature, Whiteboard: [metro-mvp][LOE:1][metro-it2][completed-elm])

Attachments

(2 files, 1 obsolete file)

This bug is to implement the new find bar. The code can probably re-use the Appbar XBL control.

Find on page:
https://www.dropbox.com/s/m3xi76x54upti9x/Find%20on%20page%20video%20sketch.pdf

Needed before we can start on it:
The previous, next, and close buttons from shorlander.
Attached the screenshot of Find Bar. We will need icons for: 
- search (same with desktop, normal state)
- preview and next btn (normal state, hover state, pressed state, disable state)
- close btn(normal state, hover state, pressed state)
Attached patch WIP patch (obsolete) — Splinter Review
I started to work on this a couple times but kept getting pulled away for different bugs.  Posting my work in progress for someone else to take over.
Assignee: netzen → nobody
Product: Firefox → Firefox for Metro
Version: unspecified → Trunk
Whiteboard: [metro-mvp][LOE:1][metro-it2]
Keywords: feature
Component: General → Theme
Duplicate of this bug: 801018
Assignee: nobody → netzen
Attached patch Patch v1Splinter Review
As best as I can match the UI mockup.  I'm not sure how to properly match it exactly given different resolutions so did something close.  I don't do very many theming type bugs so any suggestions are appreciated.
Attachment #665887 - Attachment is obsolete: true
Attachment #693163 - Flags: review?(mbrubeck)
Attachment #693163 - Flags: review?(mbrubeck) → review+
Summary: Implement the new Find bar → Implement new theme for the Find bar
We can do touchups in followup bugs:
https://hg.mozilla.org/projects/elm/rev/a476ab437ee1
Whiteboard: [metro-mvp][LOE:1][metro-it2] → [metro-mvp][LOE:1][metro-it2][completed-elm]
Resolving bugs in the Firefox for Metro product that are fixed on the elm branch.  Sorry for the bugspam.  Search your email for "bugspam-elm" if you want to find and delete all of these messages at once.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Blocks: 831935
Blocks: 831940
Blocks: 831941
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.