Last Comment Bug 774933 - "Assertion failure: any" in AutoGCSession::AutoGCSession with verifybarriers
: "Assertion failure: any" in AutoGCSession::AutoGCSession with verifybarriers
Status: VERIFIED FIXED
[js:p1]
: assertion, regression, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- critical (vote)
: mozilla17
Assigned To: Bill McCloskey (:billm)
:
Mentors:
Depends on:
Blocks: 594645 774104
  Show dependency treegraph
 
Reported: 2012-07-17 16:29 PDT by Jesse Ruderman
Modified: 2012-11-06 14:27 PST (History)
7 users (show)
jruderman: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
affected
verified
unaffected


Attachments
testcase (317 bytes, text/html)
2012-07-17 16:29 PDT, Jesse Ruderman
no flags Details
stack trace (5.62 KB, text/plain)
2012-07-17 16:29 PDT, Jesse Ruderman
no flags Details
patch (1.15 KB, patch)
2012-07-19 15:57 PDT, Bill McCloskey (:billm)
terrence: review+
Details | Diff | Splinter Review

Description Jesse Ruderman 2012-07-17 16:29:01 PDT
Created attachment 643180 [details]
testcase

1. Install https://www.squarefree.com/extensions/domFuzzLite3.xpi
2. Load the testcase in a debug build (from the command line?)

Assertion failure: any, at js/src/jsgc.cpp:3570

I can reproduce using https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-macosx64-debug/1342515922/ but not using a local debug build :(
Comment 1 Jesse Ruderman 2012-07-17 16:29:40 PDT
Created attachment 643181 [details]
stack trace
Comment 2 Bill McCloskey (:billm) 2012-07-19 15:57:05 PDT
Created attachment 644054 [details] [diff] [review]
patch

I forgot to call Prepare before the GC. Regression from bug 774104.

This API is kinda crappy. I'm going to work on simplifying it soon.
Comment 4 Ed Morley [:emorley] 2012-07-20 06:53:56 PDT
https://hg.mozilla.org/mozilla-central/rev/b3de7703f20b
Comment 5 Daniel Veditz [:dveditz] 2012-08-02 16:34:17 PDT
(In reply to Bill McCloskey (:billm) from comment #2)
> I forgot to call Prepare before the GC. Regression from bug 774104.

Based on that marking this tracking for Fx16
Comment 6 Alex Keybl [:akeybl] 2012-08-23 17:02:26 PDT
Can we get this nominated and landed on Aurora 16 prior to Monday's merge?
Comment 7 Bill McCloskey (:billm) 2012-08-26 23:45:51 PDT
This assertion is more of a sanity check. I don't think anything bad will happen if it's violated, so I don't think we need this on Aurora.
Comment 8 Alex Keybl [:akeybl] 2012-08-27 10:07:31 PDT
(In reply to Bill McCloskey (:billm) from comment #7)
> This assertion is more of a sanity check. I don't think anything bad will
> happen if it's violated, so I don't think we need this on Aurora.

Thanks Bill - we'll untrack in that case.
Comment 9 Virgil Dicu [:virgil] [QA] 2012-11-05 06:20:38 PST
Can't reproduce the assertion with the latest beta debug build (http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012-11-04-mozilla-beta-debug/) but couldn't reproduce with a build from the report date either so i'll leave the verified status as is for the moment.
Comment 10 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-11-05 09:40:35 PST
Jesse, can you see if this is still reproducible for you? QA is not able to reproduce on the reported build.
Comment 11 Jesse Ruderman 2012-11-05 13:34:33 PST
Fine on trunk.  I tested with "verifyprebarriers", the closest equivalent to the "verifybarriers" that existed at the time of filing, and also with "verifypostbarriers".
Comment 12 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-11-06 14:27:16 PST
Thanks Jesse.

Note You need to log in before you can comment on or make changes to this bug.