Copying a profile with a disabled restartless add-on to a different directory causes extensions to fail to load

RESOLVED FIXED in Firefox 15

Status

()

Toolkit
Add-ons Manager
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: al_9x, Assigned: mossop)

Tracking

15 Branch
mozilla17
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox15+ verified, firefox16+ fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
the error log shows:

Timestamp: 7/18/2012 2:03:34 AM
Error: ERROR addons.xpi: Error processing file changes: TypeError: bootstrap is undefined
Source File: resource:///modules/XPIProvider.jsm
Line: 2412

Could not read chrome manifest 'old jar absolute path'. <- for every extension

the a bunch of these for many resources of various extensions:

No chrome package registered for chrome://tabmixplus/content/overlay/browsroverlay40.css

restarting Fx once or twice, fixes the problem, but this worked flawlessly before 15
(Reporter)

Comment 1

5 years ago
This is caused by a disabled firebug 1.10, without it, or if enabled, there is no problem after copying
(Reporter)

Comment 2

5 years ago
But Fx 15 is a factor, no problem in 14
(In reply to al_9x from comment #1)
> This is caused by a disabled firebug 1.10, without it, or if enabled, there
> is no problem after copying
I don't understand this. If Firebug is disabled how it could cause the problem?
Does it mean that it's Firefox issue?

Honza

Comment 4

5 years ago
Yes, the bug description clearly indicates that extensions.ini didn't get updated - that would be a Firefox issue.
(Reporter)

Comment 5

5 years ago
I don't understand either, but it's consistent.

@Wladimir - I cced you because you recently blogged about restartless extensions.  This seems to have something to do with that.  In fact the same thing happens with a disabled abp instead of firebug.  It's as if Fx tries to call into the disabled restartless extension on first start after copying, expecting it to do something, which it doesn't.
(Assignee)

Comment 6

5 years ago
Does this happen with 16 or 17?
(Assignee)

Comment 7

5 years ago
Nevermind, looks like this is some kind of regression caused by bug 744833
Blocks: 744833
tracking-firefox15: --- → ?
(Assignee)

Comment 8

5 years ago
How are you copying the profile files? Is there any chance that prefs.js isn't included in the copy, since that would probably cause this issue.
(Reporter)

Comment 9

5 years ago
everything is copied
(Assignee)

Updated

5 years ago
Assignee: nobody → dtownsend+bugmail
(Assignee)

Comment 10

5 years ago
This happens whenever there is a disabled restartless add-on in the profile.
tracking-firefox16: --- → ?
Summary: 15.0 regression: on first start after copying a profile to a different user on a different machine extensions fail to load → Copying a profile with a disabled restartless add-on to a different directory causes extensions to fail to load

Updated

5 years ago
Status: UNCONFIRMED → ASSIGNED
tracking-firefox15: ? → +
tracking-firefox16: ? → +
Ever confirmed: true
(Assignee)

Comment 11

5 years ago
Created attachment 644021 [details] [diff] [review]
patch rev 1

Silly mistake here, if the add-on is disabled then it won't be in bootstrappedAddons so everything goes horribly wrong.
Attachment #644021 - Flags: review?(bmcbride)
Attachment #644021 - Flags: review?(bmcbride) → review+
(Assignee)

Comment 12

5 years ago
On inbound: https://hg.mozilla.org/integration/mozilla-inbound/rev/ef2285d68618

Once it passes a few days on nightly I'll see about getting it pushed to aurora and beta.
https://hg.mozilla.org/mozilla-central/rev/ef2285d68618
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla17
(Assignee)

Comment 14

5 years ago
Comment on attachment 644021 [details] [diff] [review]
patch rev 1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 744833
User impact if declined: it's a rare case so few users will see the issue, but it is also a very safe and simple fix.
Testing completed (on m-c, etc.): m-c for a few days, it's not a common path though so the automated testing are our main source of testing here
Risk to taking this patch (and alternatives if risky): extremely safe
String or UUID changes made by this patch: none
Attachment #644021 - Flags: approval-mozilla-beta?
Attachment #644021 - Flags: approval-mozilla-aurora?
Comment on attachment 644021 [details] [diff] [review]
patch rev 1

[Triage Comment]
Since we're still early in the beta cycle, and this is a low risk FF15 regression fix, let's take the fix even though it's likely to be a rare user issue.
Attachment #644021 - Flags: approval-mozilla-beta?
Attachment #644021 - Flags: approval-mozilla-beta+
Attachment #644021 - Flags: approval-mozilla-aurora?
Attachment #644021 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 16

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/11d7c076de51
https://hg.mozilla.org/releases/mozilla-beta/rev/d11eb233d8ec
status-firefox15: --- → fixed
status-firefox16: --- → fixed
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0

Verified in Firefox 15 beta3 after copying profile with Firebug disabled. No extension.log.
status-firefox15: fixed → verified
(Assignee)

Updated

5 years ago
Blocks: 780690
You need to log in before you can comment on or make changes to this bug.