Last Comment Bug 775010 - autocomplete.css is not preprocessed on Windows XP
: autocomplete.css is not preprocessed on Windows XP
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Location Bar (show other bugs)
: Trunk
: All Windows XP
: -- normal (vote)
: Firefox 17
Assigned To: Andrew Hurle [:ahurle]
:
Mentors:
Depends on: 587909
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 00:29 PDT by Andrew Hurle [:ahurle]
Modified: 2012-07-23 14:03 PDT (History)
1 user (show)
MattN+bmo: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Very intricate patch to preprocess autocomplete.css (1.16 KB, patch)
2012-07-18 00:39 PDT, Andrew Hurle [:ahurle]
MattN+bmo: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Andrew Hurle [:ahurle] 2012-07-18 00:29:40 PDT
bug 758354 stopped preprocessing autocomplete.css, but bug 587909 now needs that file to be preprocessed on XP.  Wasn't caught after rebasing.  Consequently, results in XP are a bit closer together than intended and the highlight style is different.
Comment 1 Andrew Hurle [:ahurle] 2012-07-18 00:39:50 PDT
Created attachment 643285 [details] [diff] [review]
Very intricate patch to preprocess autocomplete.css
Comment 3 Ed Morley [:emorley] 2012-07-18 05:52:36 PDT
https://hg.mozilla.org/mozilla-central/rev/ce577fd16506
Comment 4 Dão Gottwald [:dao] 2012-07-19 05:19:28 PDT
I assume you're going to land this on aurora?
Comment 5 Andrew Hurle [:ahurle] 2012-07-19 15:18:45 PDT
Comment on attachment 643285 [details] [diff] [review]
Very intricate patch to preprocess autocomplete.css

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 587909, bug 758354
User impact if declined: Awesomebar results would be harder to read for XP users because they're closer together.  Fix would land a version later in Firefox 17.
Testing completed (on m-c, etc.): Yes, see m-c/m-i pushes above
Risk to taking this patch (and alternatives if risky): Low
String or UUID changes made by this patch: None
Comment 6 Alex Keybl [:akeybl] 2012-07-23 11:50:42 PDT
Comment on attachment 643285 [details] [diff] [review]
Very intricate patch to preprocess autocomplete.css

[Triage Comment]
Styling fix and very early in the cycle, approved for Aurora 16.

Note You need to log in before you can comment on or make changes to this bug.