If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

java.lang.NullPointerException: at org.mozilla.gecko.ScreenshotHandler$1.run(GeckoAppShell.java)

RESOLVED DUPLICATE of bug 766647

Status

()

Firefox for Android
General
--
critical
RESOLVED DUPLICATE of bug 766647
5 years ago
5 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression})

16 Branch
ARM
Android
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [native-crash], crash signature)

(Reporter)

Description

5 years ago
It first appeared in 16.0a1/20120714. The regression range might be:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6489be1890c0&tochange=0602e44ac248

Here is a crash report: bp-fa072789-b17c-4dcb-9640-a53e92120718.

java.lang.NullPointerException
	at org.mozilla.gecko.ScreenshotHandler$1.run(GeckoAppShell.java:2536)
	at android.os.Handler.handleCallback(Handler.java:605)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at org.mozilla.gecko.GeckoBackgroundThread.run(GeckoBackgroundThread.java:31)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.ScreenshotHandler%241.run%28GeckoAppShell.java%29
This is likely due to getLayerController() returning null because of the "don't keep activities" checkbox (similar conditions to bug 774156). My patch for bug 766647 includes a null check to guard against this.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 766647
You need to log in before you can comment on or make changes to this bug.